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Two Kinds of Reports in Genesis

In Genesis, some screens have built-in reports. The first part of this chapter, ‘The Printer
Icon’, describes how to access and print these screen-specific reports. In addition, each
Genesis module has its own extensive set of reports. These are found on a series of
Reports screens. There is one Reports screen for each Genesis module:

Student Data>Reports
Attendance—>Reports
Scheduling>Report

Next Year Scheduling>Reports
Grading2>Reports
Registration>Reports
Conduct>Reports
Administration>Reports

The operation of the built-in reports differs from the operation of the reports listed on one
of the Reports screens. This chapter is divided into two parts, reflecting the two types of
operation:

1. The Printer Icon — A Screen’s Default Report
2. Genesis Reports Tabs
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The Genesis Printer Icon

On some Genesis screens a small printer icon is visible as the first icon in the set in the
upper right hand corner of the screen. When it is present, the screen has its own built-in
report. When the Printer Icon is not present, the screen has no built-in report.
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Figure 1 - student Data>Student List screen illustrating the printer icon
When the printer icon appears, the screen has a built-in report.

To access the built-in report for a screen, click the Genesis printer icon. This causes the
report to be run and the resulting PDF file to be displayed in the browser.

Genesis uses Adobe’s Adobe Reader 6.0 to display and actually print reports. Adobe

Reader 6.0 takes over the browser and displays the report. The user can then use the
Adobe Reader controls to send the report to a printer. This is illustrated below:
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The result of clicking the printer icon on the Student Data—> Student List screen:
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Figure 2 - Student Data->Student List report displayed via the Adobe Reader

To Control the Display:
Use the Adobe tabs shown at the left edge of the display are used to page through the
report.

To Print the Report:
a. Click on the “Print” icon shown at the top of the Adobe Reader display. DO
NOT use the browser’s own File>Print menu item.
b. The standard Print Dialog will appear:

NOTE: ADOBE READER has taken over the screen. Genesis has temporarily
given up control.

NOTE: DO NOT USE THE BROWSER File>Print to print the report. ONLY use the
Adobe ‘Print’ icon.
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Figure 3 - The Standard Print Dialog is displayed and user selects the desired printer and clicks ‘OK’

c. The user selects the desired printer from the print dialog and clicks ‘OK’. The
report is printed on the selected printer.
d. To return to Genesis, the click the browser’s BACK button.

NOTE: The Browser BACK Button

When using Genesis, the browser’s own BACK button should ONLY be used to
return to Genesis from printing a report via Adobe Reader. It should never be
used at any other time.

1/28/2007

Page 4 of 17



Genesis Student Information System User Documentation

1. Genesis Report Tabs

A large number of Genesis Reports can be found on the Genesis ‘Reports’ tabs. Every
Genesis Module contains a “Reports” category tab:

Q-0-HRG PHe - UM A998 _ -2
Genesis etven [ B I @ 0 8000w e B

How Da L. |[Choose... « 10y

LU VR EN | Ragistration  Scheduling next Year Scheduling | Grading | Attendance | Calendar  Transcript Selup et p

" StudentList | EditLists  Labsls  SetNext School & Gragf  Reports Y NI Tesling

Student Data.Student List A 4 \/ . , .
Student Search Form A ReportS tab IS

Last Name: Schools: 2002 present under each
First Name: Studant 10: R
Grades: . Tale actve Sodens only 8 Genesis top tab.
Gender} * | Special Ed Fiag: ¥ | Homeroom:
Counselon s Student List:
Vice Principal:] v ESL/LEP: v
Search Resat
ﬁ m First Nama school HR GR Gender Enrollment Status P =
r- 1000611 ARDUL - HAKEEM SAKINAR 2002 GYM-A 12 F ACTIVE lﬂ
[ 1o05633 ABOUL- RAHEEM AEISHAH 2002 D262 11 F ACTIVE [ﬂ
[ ioossss ABLAZA, IR LAZIR 2002 F114 11 M ACTIVE |_“_\‘]
[ laoaszx ABRAMAM ALEX 2002 D23z 1w M ACTIVE )
[ |igeiz3z ABREGD PATRICIA 2002 218 1w |F ACTIVE &
[ |seszze ABREY ROBERT 2002 D202 1M ACTIVE el
[ lios107 ACOSTA ALICIA 2002 GYM-A 12 M ACTIVE R
O |ouuass ACOSTA GABRIEL 2002 D250 1M ACTIVE =)
[0 lios268 ADAM REBECCA 2002 D238 1 F ACTIVE =
[ |sosaez ADAM HEBECCA 2002 C102 0 F ACTIVE L]
|—_ 1010590 ADAMS ANDRICO 2002 GYM-A 12 F ACTIVE RPR lg
|—: AGIS0T ADAMS (CARL 2002 208 10 ™ ACTIVE lg
[ linsasze ADESHINA ‘SAMUEL 2002 c1ae 1 m ACTIVE =)
[ 403067 ADEVA RICHELLE 2002 GYM-P s |F ACTIVE =
[} lspasan ADEVA IROXANNE 2002 F140 12 F ACTIVE |’§‘|
(1 1911803 ADLAKHA AMIT 2002 oM ACTIVE |
(®) add chocked students to this kst: |42 ¥ () Add checknd studants to a niw kst (8.3
2269 Syudents, GComyriaht Genesis Educationsl Servsenine,
48] 2269 students. P Internet

Figure 4 - Student Data->Reports Tab illustrated

View A List of Reports:
To view the list of available reports, click the “reports™ tab. This brings up a screen
listing all the reports available to you in the selected module.
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The Reports screens list all reports available to the user.

Seq Mame Last Run Last Run By ]
20995 Damegraphic Data and Address Profiles 2004-10-21 10:21:53.0 mzghd IEHRLEE-)
20997 District ESL-LEP Report 2004- 10-25 09:53:10.0 blazar ERELEE- )
20959 District ESL-LEP Schoel Summary Report a

21000  District Roster by Grade 2004-10-19 09:47:34.0 \zih ICHELEE=)
21010 Districk Student Roster 2004- 10-14 DB:44:04.0 nzitr ERNLEE-)
20956 (ESL-LEP Report for 1 Schoal 2004- 10-20 08:53:29.0 droo H S| 2
21020 |Ethnic Summary by Grads Race and Sex 2004-11-05 08:36:26.0 forge ERELRE- )
21030 Food Servica Report 12004-10-25 09:53:54.0 blazer ‘3 ';k _:J
21035 Grade Gendar Race Raport 2004- 11-03 09:06:18.0 forge g ;L )
21040 List with C for 1 2004-10-19 14:32:34.0 blazar ICHEGEE]
21050 List with Cl All 2004~ L1-06 22:19;42.0 farge E] ;L =]
21055 Homarcom PTA Call List 2004-10-21 13:57:47.0 blazer E ;"‘ =)
21060  Homercom Regéster Check for 1 Homercom 2004-10-22 15:55:28.0 class IENBCEE:]
21070 Homereom Ragester Chack for all Homercoms 2004-10-11 10:56:46.0 blazes E :" e |
21080 Homeroom Foster for 1 Homaroom 2004-10-25 17:36:52.0 qlsmn E ;L 5]
21090 Home‘mnm Roster for All HRs with Bus Info 2004-10-22 15:56:33.0 class @ :L ]
21100 Homercem Rester for All Homerooms 2004-10-32 08:27:27.0 aporh @ ;L' =
21110 Homereom Roster with Ethnic Codes 2004-10-21 14:09:12.0 blazer @ :L =
1130 Homaroom Roster with Teacher & Bus Info F004-10-17 22:16:41.0 blazer g8 % a8
1131 Homareom Roster with Taachar for 1 Homaroo! m F004-10-13 08:55:07.0 class 8 5 9
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Figure 5 - Sstudent Data>Reports Tab displayed. Standard Reports screen layout is shown.

SECURITY NOTE:
Reports listed on a single Reports screen will be different for different users. Access to
reports is controlled by your Genesis Roles. Users are assigned different Roles, thus the

users will be able to see and run different collections of reports.

Layout of Reports Screens
All reports screens have the same layout. There are 7 columns:

NogakowhE

The Report Number

The Name of the Report

Last Run Date

User Id of Last User to Run the Report
The ‘Run Report’ icon

The “Display Last Run’ icon

The ‘Report Archive’ icon
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Report Screen Layout, Cont.
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Figure 6 - Student Data>Reports Tab displayed. Columns are Illustrated.

Running a Report
To run a report listed on a Genesis Reports screen, click the ‘Run Report’ icon in column
5.

There are 5 steps to printing a report:

1. Select the report and click the *‘Run Report’ icon. This brings up the ‘Run
Report’ dialog shown below.

2. Set any necessary parameters for running the report. Some reports have no
parameters and other reports will have as many as 6 or 7 parameters that must be
set.

3. Click the *schedule Report’ button to start the report processing. When
processing is completed, the report is displayed by the Adobe Reader in the center
of the Genesis screen.

4. To actually print the report, click the Adobe Reader ‘pPrint’ button. This brings up
the standard Windows Printer Dialog

5. Select the desired printer and click ‘ok’. The report prints on the desired printer.
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Initiating a Report — The Report Invocation Screen
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Figure 7 - Reports invocation screen. Fields are illustrated.

Report Invocation Screen
To start running the report, the user must enter all required parameters and click the
‘Schedule Report’ button.

Many reports do not take parameters, the user need only click the *Schedule Report’
button to start running the report.

Sending the Report as Email to Oneself

If email is set up for Genesis, the user can click the ‘E-mail a copy of the report’
checkbox and a copy of the report PDF file will be sent to the user’s email address.
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Waiting for a Report to Complete
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Figure 8 — Report is Running screen. Fields are illustrated.

Waiting for the Report
This screen is displayed if you choose to wait for the report to complete.

NOTE: You DO NOT have to wait for the report to complete. The report will run to
completion whether or not you stay on this page and wait. You can then use the “View
Last’ icon to bring up the completed report.

The fields in the display include:

Status — is the report running or ‘queued’ waiting to run

Message — the Report software can send updates to let you know how it is progressing.
Queued On - time when the report was initiated

It’s Now — Current time. This shows how long the report has been running.

Name — Name of report

Description — Description of the report

E-Mail Report — indicates if the report output will be emailed or not.
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Displaying and Printing the Finished Report
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Figure 9 — Report display. Adobe Reader controls the center portion of the screen to display the report
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Viewing and Printing the Report

DCooyright Genesis Educatonal Services.Inc.
& Intermet

Genesis exclusively uses Adobe Reader 6.0 to display the finished report. This allows
the report to be viewed before it is printed: many reports can be discarded without ever

being printed, saving paper and money.

Printing the Report

To print the report, click the ‘Print” button at the top left of the Adobe Reader frame. DO
NOT use the browser’s own File>Print menu item, it does not work correctly to print

the report.

Clicking the Adobe Print icon brings up the standard Windows Print Dialog.
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Printing the Report, Cont.

Printer
NP |/ 0L FHP Office.Jet R0xi v| Properties
Status:  Ready [ Printto file
Type: HF OfficeJet R80xi
Print Range Prewiew
@Al
C} Current visw
() Current page K 1 4
() Pages fram: 511 I to: 112 J 7=

Subset [Allpages inrange v |[[|Reverse pages

Page Handling

Copies: i ?: 85

Fage Scaling: E—Fitto paper o

Sl

Auto-Fotate and Center

[ ] Choose Paper Source by POF page size

PrintWWhat: IDucument

[ €

Units: Inches Zoom: 94%

[PrintingTipsl [ Advanced ] ’ Ok l \ Cancel I

Figure 10 — standard Windows Print Dialog.

The standard Windows Print dialog allows you to select any printer available to you and
to control the printing of the document in the usual way.

NOTE: This is not controlled by Genesis — This is a standard Windows Service.

Click ‘OK’ to print the Report or ‘Cancel’ to return to the Report Display screen.
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Returning to Genesis from the Report Display Screen
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Figure 11 — Report Display. Click any tab to move out of this screen.

NOTE: DO NOT USE the browser BACK button to leave this screen. Genesis is
still in control of the screen — note the Genesis tabs. To leave this screen, simply click a
different Genesis tab.

Returning to the Reports Screen
To return to the Reports screen to select a new report, click the “reports” tab.
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Scheduling a Report for Later Execution

Reports need not be run immediately: they can be scheduled for a later time and or later
date.
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G' EE)ES ;_5 Z GENLSIS School District T P E-CUIGIEIEE: B (o]

School Year: | 2004-05 (% GENESIS High School v Genesls Adminis

HoW Do .., (Choose... = Inbox (0}
LU ERVE R Ragistration Scheduling next Year Scheduling | Grading | attendance | Calendar  Transcript Selup I Next b i

Student List Edit Lists Labels et Next School & Grade [ Reparts | N1 Testing
Student Data.Student List

f T Y Run Report |
Hun a report Report: imuermnuagisterMChecking the ‘Run
G e Immediately” checkbox brings up
s e the “Schedule Report’ fields

Sun Mon Tue Wed Thu Fri Sat
i 4 3 4 5 &
8 9 10 11 (12 13
15 W% 17 18 19 20
22 23 24 25 2@ 27
24 30

‘Schedule Report’ fields include
both date and time fields. Clicking
the calendar icon brings up a
calendar to allow you to select a
date.

ECopyriaht Genesis Educationsl Services,inc,  d

&l P Internet
Figure 12 - Reports invocation screen with ‘Schedule Run’ fields showing

Do Not Run Report Immediately: Schedule for Later

1. Uncheck the ‘Run Immediately’ checkbox. This causes the Schedule Report
fields to appear.

2. Setthe Run Date. The date DOES NOT automatically defaults to “today”. The
user must select the run date.

3. Select the time to run the report. The ‘am/pm’ drop down is used to select AM or
PM.

4. Click the ‘schedule Reports’ button to schedule the report. The report will run at
the appointed date and time.
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Retrieving the Last Run of a Report
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31131 |Homaroom saster wih Tascher fo 1 Homaroom last run of the report. The ‘Last
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Figure 13 - Reports screen illustrating the ‘Last Run’ icon column

Viewing the Most Recent Run of a Report
1. Select a rReports tab to bring up a Reports screen.
2. Identify the report you wish to view.
3. Click the middle icon, the ‘View Last Run’ icon. This causes the most recent run
of the report to be loaded into the browser under the control of the Adobe Reader
(See above).

Report Archives

Most reports only save the most recent run. However, some reports retain all previous
runs. These can be found on the Reports>Archive screen and are accessed via the
‘Archive’ icon.
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Archived Reports

Certain reports are set to save all their runs. The Reports—=> Archive screen is used to
view the list of archived runs for a single report.

Q- © HEn ke 2-23 . OE 293
Genesis School Year: [2004-05 T — 9 S imo ey

How Do L.. Choose.,, % tnbox £0)

Student Data '-le_pgisrrmlnn- “Smedu!ing' 'i_'.-ur Year Sr.h-a-:lllllnﬁ -Graﬂhm' 'am-udam_z-' "c.]ll-ndar Traust_rlpl' - Setup i MNest p

Student List  EditLists  Labels  Set Next School & Grade [ Reports | NI Tasting

Pt Datn Stk Lt S5

i T < ! archive | )
Homeroom Roster for All HRs with Bus gchive /\ A
£ i ]
: ]
£ o]

Completad On Run By Engine Message
11/12/2004 11:55 AM admin Success

09/05/2004 D2:38 PM admin Success
09/05/2004 D2:37 PM admin Success

Note: Archive tab . .
Display icons

Delete icons

BCapyriaht Gerssis Educational Services I,
&] Done & Ineernet

Figure 14 — Reports>Archive screen for a report with multiple runs archived

Information on Each Run
- Run date and time
- User Id of user who ran report
- Success or failure message

Bringing Up an Archived Run of a Report
1. Select the desired report
2. Click on the “Display’ icon. This loads the report into Adobe Reader.

Deleting a Single Run:
1. Select the desired report
2. Click on the ‘Delete icon’. This removes the run from the list and the archive.

To Return to Report List:
Click the reports tab.
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HOW DO 1?

Print a Genesis Report?

1.

2
3
4
5.
6.
-
8
9
1

Click on a Reports tab (Student Data>Reports, Attendance->Reports,
Grading2>Reports, Scheduling>Reports, Conduct%ReportS,...).

Locate the report you wish to run.

Click on the ‘Run Report’ icon

Enter any needed parameters

Click on ‘schedule’

Wait for the report to complete. Some reports can take up to 15 minutes.
Click on the Adobe Reader ‘Print’ icon

Select your desired printer.

Click ‘ok’

0. Click any Genesis tab to move to a new function.

Retrieve and Print the Last Run of a Report?

1.

NG~ WN

Click on a Reports tab (Student Data->Reports, Attendance>Reports,
Grading>Reports, Scheduling>Reports, ConductéReports,...).

Locate the report you wish to print.

Click on the ‘Last Report’ icon

Wait for the report to load

Click on the Adobe Reader ‘print’ icon

Select your desired printer.

Click ‘oK’

Click any Genesis tab to move to a new function.

Print the Genesis Report for the Current Screen?

1.

Nogakown

Locate the Genesis printer icon, first in the series of icons at the upper right
corner of the screen. If there is no printer icon, there is no report for this
screen.

Click the printer icon

Wait for the report to complete

Click on the Adobe Reader “print’ icon

Select your desired printer.

Click ‘oK’

Click the browser’s own ‘Back’ button to return to Genesis

Schedule a Report to Run Later?

1.

Nogakown

Click on a Reports tab (Student Data>Reports, Attendance>Reports,
Grading=2>Reports, Scheduling>Reports, Conduct—)Reports,...).

Locate the report you wish to run.

Click on the ‘Run Report’ icon

Enter any needed parameters

Uncheck the ‘Run Immediately’ check box

Select a run date and time.

Click ‘schedule’
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8.
9.

Click ‘OK’ to the “‘Report has been scheduled’ popup.
After report has been run, print the archived report.

Print an Archived Report?

1.

BOO~NOUOR~WDN

0.

Click on a Reports tab (Student Data>Reports, Attendance>Reports,
Grading2>Reports, Scheduling>Reports, ConductéReports,...).

Locate the report you wish to print.

Click on the ‘Archived Reports’ icon (right-most icon)

Select the version of the report to print

Click on the ‘view Report’ icon (left-most icon) for the selected report
Wait for the report to load

Click on the Adobe Reader ‘print’ icon

Select your desired printer.

Click ‘ok’

Click the browser’s own ‘Back’ button to return to Genesis

Delete a Report from the Archive?

1.

NG WN

Click on a Reports tab (Student Data>Reports, Attendance->Reports,
Grading2>Reports, Scheduling>Reports, Conduct%ReportS,...).

Locate the report you wish to print.

Click on the ‘Archived Reports’ icon (right-most icon)

Select the version of the report to delete

Click on the “Delete Report’ icon (right-most icon) for the selected report
Click ‘ok’ to the “Are you sure you want to delete this report?” popup
Click ‘ok’ to the “Report successfully deleted.t”” popup

Click the browser’s own ‘Back’ button to return to Genesis

Find Out Who Last Ran a Report?

1.

w

Click on a Reports tab (Student Data>Reports, Attendance>Reports,
Grading=2>Reports, Scheduling>Reports, Conduct—)Reports,...).

Locate the report you wish to check on.

Locate the ‘Last Run By’ column

Read the user id of the person to last run the selected report.

1/28/2007 Page 17 of 17



