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Outline for Completing an InRoads Project

Note: Before beginning a project in InRoads, existing dtm and alg files are necessary. For Microstation, a
Topo file is needed. These can be retrieved through the intranet-
Internet Explorer:   http://intranet/engrgrp/survey/fsvarch/

I. Open and Create Files (Chapter 1)
A. Open Preference file (xin) from the R drive. Save to the project folder.
B. Set up a project default for the new project
C. Open the original surface (dtm) and Geometry Project (alg) files.

D. Open the seed Typical Section Library (Basic Template Library.itl) and save to the project folder as 
new name.
E. Open Roadway Designer Library (ird) and save to the project folder (this will be an empty file until the 
corridor is built).

F. Review the original surface and the geometry project.
G. Create a Project File (rwk).

II. Create the new Horizontal (Chapter 2)
A. File >New >Geometry > Horizontal Alignment
B. Geometry > Horizontal Curve Set > Add PI

C. Once all the PIs are added, Geometry > Horizontal Curve Set > Define Curve to add the radius of each
curve.

D. Enter the Event points and any equations to the alignment
OR......if given station and offset from CL Survey or northing and easting, use COGO

1. Geometry >Cogo points > New
2. Define by station and offset or northing and easting
3. As the points are created record the numbers 
4. Geometry > Utilities > Create/ Edit Alignment by Cogo Points
5. Name the alignment
6. Key in the points
7. Once all the PIs are entered use the Define Curve command to enter curve information
8. Station the alignment and add event points and equations

III. Create a Vertical Alignment (Chapter 3)
A. Generate A Profile.

B. Create a NEW Vertical Alignment under the active Horizontal Alignment.
C. Add P.I.’s to the Vertical Alignment.
D. Use the Vertical Curve Set command to add curve lengths to the Vertical Alignment.
E. Save the Geometry Project.

IV. Create a Template (Chapter 4)
A. Retrieve the Basic Template Library
B. Save the Template Library from the R drive to the job folder and name it for the project.
C. Create the template using the prebuilt segments.
D. Edit the pieces to fit the specific job including pavement depth.
E. Add end conditions to the template and edit them for the project.
F. If there is superelevation on the project, ensure the top layer shoulder components are set to 

triangulate.
E. Save the Typical Section Library.

V. Create A Roadway Design. (Chapters 5)
A. Create a Corridor.
B. Create Template Drops.
C. If necessary create Template Transitions or use point controls.
D. Run through the “cross sections” view and adjust where necessary. 

http://intranet/engrgrp/survey/fsvarch/


VI. Create Superelevation (Chapter 5)
A. In Roadway Designer... Superelevation > Create Superelevation Wizard > Table

B. Load the table for the project from R:\CADD_Support\Design\InRoads\superelevation
C. Highlight the desired curves and select Load Values from Table. Once all the curves are finished select 
the Next button

D. Select Add on the sections box & define curves with range and crown points
E. Right click in the superelevation window and set the shoulder rollover locks
F. Return to the template library and turn off triangulate on the top layer shoulder components, then 

save.
G. Synchronize the template drops and save the Roadway Designer

VII. Run Roadway Designer (Chapter 5)
A. Go to Corridor>Create Surface.
B. Select desired Corridor and select the existing Surface.
C. Name the surface and make the desired setting selections.
D. Apply the create surface.
E. Save Design Surface (dtm).

VIII. Create Plan & Profile Sheets (Chapter 6)
A. First load the desired preference. Set the desired Horizontal Alignment. (Main Tab)
B. Set Station Limits. (Main Tab)
C. Select Model Files. (Plan Controls tab)
D. Select AND Highlight the Existing Ground (dtm)(Profile Controls tab)
E. Select the Host File Name. (Sheet Layout tab)
F. Select the Seed Host File. (Sheet Layout tab)
G. Enter the J.P. Number User Text 1 and County Name User Text 3 (Border & Title tab)
H. Click Apply and data point in view.

I. View the vertical alignment in the profile with the update profile command and annotate it. Annotate finished
grades as well.

J. View the structures in Plan and Profile and drives in the Plan. Annotate them.
K. View the horizontal alignment in the Plan view and place curve set annotation and stationing.

L. View the top of cut and toe of slope features in the Plan view and annotate.

IX. Create a Set of Cross Sections (Chapter 7)
A. Load the preference inside the create cross section command and set the desired Horizontal Alignment.

B. Select the desired surfaces.
C. Generate Cross Sections and label JP #County and sheet numbers.
D. Annotate F.G. and ditch elevations

E. Drape the Cross Sections. This includes: utilities (i.e. gas lines, tug lines, and underground power lines 
and crossing utilities), pres RW, new RW, and alignments.

F. Display and annotate structures and drives.
G. Remove the existing pavement from the existing surface

H. Update the cross sections with the modified existing surface
G. Using the End Areas & Volumes command,  label the cross sections (without the fill factor).

Create a Mass Diagram
A. In the Create Cross Sections command  Select the End Area Volumes folder

B.  Select the Cross Section set needed to create the Mass from.
C. Select from the EAV General folder the surfaces to be compared.
D. Set the fill factor on the compaction expansion folder and any volume exceptions
E. Select the Mass Haul Diagram subfolder and set the Horizontal and Vertical exaggeration. Adjust 

until the desired result is achieved.
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 CHAPTER 1

    Project Preparation



Notes



         Then retrieve the Microstation seed files for the project 
from R:/CADD_Support/MicroStation/Seed 
Files/Roadway. Copy the desired files to the new 
project folder. When Renaming for a project, 
replace the 12345(04) with the project number.  For 
example: 12345(04)-Align.dgn becomes 17458(10)-
Align01.dgn 

When beginning a project, the first thing to do is 
create a project folder with an inroads folder inside. 
Then the files need to be retrieved from the intranet 
survey archives Internet Explorer:   
http://intranet/survey/data/fsvarch//

From the explorer window, press 
Ctrl+F. Key in the JP number and 
select next. The project will highlight in
the list. Open the project and double 
click on civil.  Double click on the alg 
and dtm files, select the save button 
and set the path to the new project 
folder then save the files in the inroads
folder. 
Next save a copy of the survey dgn file
located in the dgn folder in the 
archives into the project folder. Note: 
there may be multiple versions of the 
same swo…In the example below 
swo3982_1_v4.dgn would be correct. 
If there is a topo (topoid_v2) save it as 
well.

PROJECT PREPARATION

1.1

SURVEY ARCHIVES

http://intranet/engrgrp/survey/fsvarch/


From the InRoads Commands select File>Project Defaults (Q>6)

Click the new button to create a new 
Project Default.
Key in a Name such as the project 
number. (it can be named anything, so 
long as it makes sense). 
Select the OK button on the New 
Configuration window.

Project defaults will only be on the 
machine and under the id it was created
on.

Copy the preferences, the seed template 
library, and the notes file from the R drive. 
These files can be found in 
R:/CADD_Support/Design/InRoads and 
should be copied to the project folder in the 
inroads folder.

Now select the Inroads icon from the desktop.  
This will launch both Microstation & InRoads. 
Select the desired Microstation file to open.

PROJECT DEFAULTS

1.2



Once the name is keyed in for the project default 
and the OK button is selected, a blank line will 
show for each of the items. Click in the box 
beside the Preferences and select the Browse 
button. From the Open window, navigate to the 
correct file and select the Open button.  The path
and file name will appear in the Default 
Preferences. Repeat this process for each item 
to have it load automatically.

The number of project defaults is virtually 
limitless.
For example: the rwk for 20231. If project 
defaults are set and an attempt is made to open
the project, it will automatically look in the folder 
set in the project defaults.
The same is true with anything saved while 
working in InRoads. It saves to the path set in 
project defaults (unless a different path is 
forced).

The items in the top box are the default 
preferences. These load automatically as long 
as the project default is set.
The items in the bottom box are know as 
Default Directory Paths.  The path set is the 
folder it will automatically find when opening the
corresponding file type

PROJECT DEFAULTS

1.3

Do not set a path for the Style Sheet (xsl) – just 
leave that one blank. 
Choose the apply button on the Set Project 
Defaults window once all desired lines are filled 
in. When finished select close on the project 
default window.
It does not have to be the same path for each 
item (if the path is the same, copy and paste is 
an option).



From the inroads menu select Fill>Open (Q>2)
Set the files of type default to InRoads files. 
Choose the existing dtm file and select open.
After the dtm is highlighted and the open button is selected a 
message will appear at the bottom of the inroads menu stating the 
existing dtm is open. 
Select the existing alg and select open..
Select the basic template library saved to the project folder. If the 
.xin file is not already open, open it as well. When finished press 
cancel on the open window.
.

Next an .ird is needed. IRD stands for 
Inroads Roadway Designer. It is also know 
as the corridor file.
From the InRoads Commands select 
Modeler>Roadway Designer (A>2).
On the Roadway Designer menu select 
File>Save As
Name the .ird file for the project and save. 
Now there is a blank corridor open. Close out
of Roadway Designer.

Creating a Project within InRoads

1.4



        Once the primary files are all open and 
saved to the machine:

Preference .xin
Alignment .alg
Surface .dtm
Template Library .itl
Roadway Design Library .ird

Create an .rwk file (InRoads Project 
file) on the inroads menu File>Save 
As (Q>4)
Select Projects (.rwk) as the Save as 
Type
Name the project 
Select the options button on the save 
as window

How to create an rwk file

1.5

Go to each of the tabs ( Surfaces, Geometry Project, XIN Preferences, Template Library, and 
Roadway Design) and make sure the add and update boxes are selected on the project files.  
Be sure that each file has the correct path (the path will show in the file name box when the file 
is highlighted). NOTE: Do not click add and update on the default files in the .dtm and .alg files.



After all the options tabs are completed, 
select the OK button on the project 
options window

Select the save button on the Save As 
window

Each time something  is added to a project, it is a good idea to use the save as on the .rwk file and 
go to the options button to make sure that  the add and update are both checked on any new item 
within the .rwk file. If there are any new files within the project, they will have to be saved before 
saving the project file or the path will have to be entered manually in the Project options window 
under the File Name box. If no path is set for the file, it will not save and any new data will be lost 
when exiting inroads.  If the file is saved, but not updated in project options, it will not load with the 
.rwk file. It will still be there, but will have to be loaded  separately.

Set up for a Project

1.6

Now when InRoads is opened, all those files do not have to be loaded individually….

Just open the .rwk file and they will all open at once

After all the options tabs are completed, 
select the OK button on the project 
options window



CHAPTER 2

 Horizontal Alignments



Notes 



On the inroads menu select Geometry>Cogo Points>New (E>I>1)
Use the define by pull down to select Easting\Northing (or station and offset, depending on 
the information provided)
If using station and offset, be sure the “alignment to offset from” is active.
The point number is automatically selected by the next available point in the cogo buffer. 
There is no need to key in a number unless a specific number is needed and it is available.
Key in the Northing and Easting (or station and offset)
Elevation 0 for the horizontal
Click apply and record the point number somewhere (note: if the report locks is on a report 
window will record the points)
The point will display in the Microstation file

Open Inroads and MicroStation.  Use the alignment 
seed file (JPNAlign01.dgn) in Microstation
that has been  named for the project. In order to do 
COGO, there must be opened alg and xin files.

COGO

2.1



Once all the points are created, Geometry>Utilities> 
Create/Edit Alignment (E>G>1) by Cogo Points
Key in the name of the new horizontal
Key in the description (if desired)
Set the style to proposed (this will determine the alignment’s
level, color, style and weight in the dgn file)
Key-in the points previously recorded (be sure to put them in
order)
Place a space between each of the numbers. 
Once all the points are entered select the apply button.
The new alignment should appear in the MicroStation 
window.

2.2

COGO



The horizontal points do not have to be created with COGO. There is 
a command for  creating PIs which can be used to create an 
alignment.
First create a new alignment using File>New (Q>1). Select the 
Geometry tab. Set the type to horizontal, key in a name and give a 
style.

Be sure the new alignment is active and on the Inroads menu select 
Geometry>Horizontal Curve Set>Add PI (E>3>1)
Watch the prompts on the Microstation screen.  Add all the desired 
PIs.

Horizontal Alignments

2.3

 Once the horizontal alignment is created, 
Geometry>Horizontal Curve Set> Define Curve
(E>3>5)

 Set the define by to Known PI Coordinates
 Enter the radius for each curve on the desired 

PI point using the next button on the bottom of 
the Define Horizontal Curve Set

Note: be sure to hit the apply button after each 
radius is entered 

 Once the radius for each curve is entered right 
click on the new alignment

 Select review from the pull down window
 This output gives a report with the alignment 

data that can be saved to the project folder



Horizontal Alignments

2.4

Another option is to draw the desired alignment in 
MicroStation.  It is important to draw the line in order 
from left to right or bottom to top. When the alignment is 
drawn in Microstation, use the element selection tool to 
select each segment in order again from left to right or 
bottom to top. 

On the Import Geometry window, key in the 
desired Name of the new alignment and set 
the Style. For the lines to be all in one 
alignment be sure to turn on the All Selected
Elements Added to Single Alignment.

From the InRoads commands select 
File>Import>Geometry (1>9>3) (from 
graphics tab)
 



Geometry>Horizontal Curve Set>Stationing (E>3>8)

Stationing the Horizontal

2.5

Select the desired Horizontal Alignment
Key in the Starting Station
Select the Apply button 

To enter a station equation, select the New 
button at the bottom of the Stationing 
window.

Select the Mode: By Station
Key in the Back Station
Key in the Ahead Station placing an “a” before the 
station.
If desired, turn on the Add Horizontal Event Point
Select the Apply button.
Repeat this for each equation on the project. 
Remember once an equation is entered, the 
stations after the first equation will begin with “a”.  
The second equation Ahead station will start with 
“b”.  The third will start with “c” and so on and so 
forth.



Stationing
This command defines the initial station and adds, 
edits, or deletes station equations. 
The Name, Northing, and Easting fields represent a 
point that will be defined with the specified station. 
Horizontal Alignment:
Select the horizontal alignment to which the 
stationing or equations will be applied. 
Starting Station:
defines the station to apply to the alignment at the 
start point. This field can also be used to set the 
stationing at a certain point on the alignment. Enter 
the station to be applied at the point that is defined in 
the Point Name, Northing, and Easting fields. After 
applying the station, this field displays the new, 
calculated starting station.
Name:
specifies the point name at which the new stationing 
will be applied. 
Northing:
specifies the northing coordinates for the station.

Stationing the Horizontal

2.6

Easting:
specifies the easting coordinates for the station. 

Vertical and Superelevation Alignments:
changes the vertical alignment to correspond to the new stationing when toggled on. Stationing is adjusted, 
maintaining the distance relationship between the start of the horizontal alignment and the start of the 
vertical alignment. When this option is toggled off, the vertical alignment remains as originally defined (that 
is, the PVI, PVC, and PVT stationing remains unchanged).
Do Not Update:

when selected, the vertical alignment remains as originally defined (that is, the PVI, PVC, and PVT 
stationing remains unchanged).
Synchronize Starting Stations:

when selected, changes the vertical alignment to correspond to the new stationing.
Maintain Station Difference:
when selected, stationing is adjusted and the distance relationship between the start of the horizontal 
alignment and the start of the vertical alignment is maintained.
Station Equations:
displays the back and ahead stations of an existing station equation on the active alignment.
New:
displays the Station Equation dialog box, which allows entering the back and ahead stations of the station 
equation to add to the active alignment.
When entering the ahead station, specify a name for the station equation first. For example, suppose station
12+00.00 back should be defined as 13+00.00. Enter the back station as 12+00 and the ahead station as 
a13+00 where “a” is a unique name.
Edit:
displays the Station Equation dialog box, which allows modification of existing station equations. Select the 
station equation to be edited before clicking Edit. 



   CHAPTER 3

     Vertical Alignments



Notes 



A vertical is stored within the .alg file (geometry project)

 To create a vertical, there must be a parent horizontal to tie it to. The first thing to do is set the 
horizontal that the vertical will be attached to as the active.

 From the Workspace bar, right click on the horizontal and select Set Active (a red box will 
appear around the icon for the horizontal). 

In Microstation, make a working profile.dgn from the seed file JPNProfile01.dgn

Vertical Alignment

3.1

 On the InRoads task menu select File>New (Q>1)
 From the New window select the geometry tab
 From the Type pull down select Vertical Alignment
 Key in the name and desired description. Select the desired style.
 Click the apply button
 The new empty vertical can be seen attached to the horizontal (select the plus sign beside 

the horizontal alignment)



 Once the new empty vertical alignment is created, it is necessary to create a profile 
Vertical Alignment

3.2

Inroads menu  Evaluation>Profile>Create 
Profile (T>1>1)

From the create profile folder 
highlight General and select the
existing surface

Highlight the Source subfolder in the 
create pull down, select window and 
data
In the alignment pull down select the 
desired horizontal (this will be the 
horizontal that the vertical is attached 
to)



After creating a profile, Geometry>Vertical Curve Set>Add PI (E>4>1). In the lower left-hand 
corner of the microstation window it will ask to identify to the alignment end. In the microstation key 
in window, enter se=station, elevation (for example: se=19600,605) Repeat this step for each 
vertical PI. Once all the PIs are entered right click to let go. 

Vertical Alignment

3.3

After all the PIs are entered, 
Geometry>Vertical Curve Set>Define 
Curve(E>4>6)
Type the curve length in the Length box
Apply to enter the length then select the next 
button to go to the next PI
Repeat these steps until all of the curve 
lengths are entered make sure to click the 
Apply button after each length is entered.



Once the vertical is finished, in the inroads 
menu in the workspace bar right click on the 
vertical alignment and select Review from the 
pull down
This will give a report of the vertical that can 
be saved to the project folder and printed for 
record

Vertical Alignment

3.4



Before going into the Text Import 
Wizard, set the Horizontal active to tie 
into the vertical(In the Geometry 
highlight the desired horizontal, right 
click and select Set Active from the 
pull down)
From the InRoads menu select 
File>Text Import Wizard (Q>8)
Wizard Name select New 
Select the ellipses at the bottom of the
window and set the path to the file 
containing the vertical text Select the 
OK button

3.5

Importing a Vertical from text

Step 1
Start Import at Line -1 (or the line the 
vertical alignment begin station is on)
End Import at Line- EOF (stands for 
end of file) or the line number the end
vertical station is on.
Select the Next button.

Step 2
Original Data Type
Set this to Fixed Width.
Select the Next button.



3.6

Step 3
Place a line to separate the columns 
by clicking in the window between the
station and elevation columns and 
between the elevation and curve 
length columns (see picture).

To change the line location, click on 
the line to make it disappear and 
place again.

Select the Next button once all the 
columns are placed.

Importing a Vertical from text

Step 4
Right click on the “Skip” headings for 
each column and select the correct 
name for each column.

Once all the columns are set to the
 correct name, select the Finish button.

If the message about changes to the .xin not being saved 
appears, it means the preference wasn’t saved from the 
preference button at the bottom of the text import screen. If
desired it can be saved. Select the Yes button on the 
message window.

Name the new vertical and select
a style. Select the Ok button. A 
new message will appear that the
alignment was successfully 
imported.  The new vertical will 
appear under the active 
horizontal.



Creating a vertical alignment in segments can be beneficial as a special ditch alignment. 
 If the template’s end conditions are built to seek the special ditch first, the special ditch
 will be built where the special ditch alignment is and where it cannot be found, the normal
 ditch or fill conditions will automatically be placed.

Creating a Vertical Alignment – 
First set the correct horizontal 
alignment active with a right click 
on the horizontal from the 
workspace bar select Set Active. 
On the Inroads menu select 
File>New (Q>1). Select the 
Geometry tab.  Set the Type to 
Vertical Alignment.

Using Vertical Elements to Create Special Ditches

3.7

The vertical element tool is an application add in. Select 
Tools>Application Add Ins (F>E).  From the Application 
Add-In window, turn on the Horizontal and Vertical 
Elements Add-In. Select the Ok button and close the 
Application Add-Ins window.



Creating a vertical alignment in segments can be beneficial as a special ditch alignment. 
 If the template’s end conditions are built to seek the special ditch first, the special ditch
 will be built where the special ditch alignment is and where it cannot be found, the normal
 ditch or fill conditions will automatically be placed.

Creating a Vertical Alignment – 
First set the correct horizontal 
alignment active with a right click 
on the horizontal from the 
workspace bar select Set Active. 
On the Inroads menu select 
File>New(Q>1). Select the 
Geometry tab.  Set the Type to 
Vertical Alignment.

Using Vertical Elements to Create Special Ditches

3.8

On the new window, key in the Name, then 
Description, and set the Style to Special Ditch. Select 
the Apply button.

Make sure the new vertical special 
ditch is active and go to
Geometry>Vertical Element>Add 
fixed line (E>6>1).  There are two 
ways to put in a vertical element:
by two points or by point distance 
and grade. Which one is used 
depends on what
Information is provided.



On the Add Fixed Vertical Line window, turn on both 
check boxes for Station and Elevation. Key in the 
desired start point station and elevation of the first 
special ditch and the desired end point station and 
elevation (or the first station and elevation and the 
desired grade). Select the Apply button and data point 
in the profile to accept.

Using Vertical Elements to Create Special Ditches

3.9

Repeat this process for each special ditch until all of them are entered.  Be sure to hit the
apply button after each one and then accept in with a left mouse click on the Microstation 
screen. 

The new vertical will look like the picture above, in separate pieces.  It is still all one alignment.
It can be reviewed, annotated and edited much like a normal vertical alignment. It can also be
targeted in the template with end conditions.



Notes 



 CHAPTER 4

     Template Creation 



Notes

              



Template Creation

The cyan colored box in the preview window represents the origin for
the displayed components (note: this point can be moved by double 
clicking on the desired point but only from the preview window)

Go to the template creator in the Inroads menu. Modeler> 
Create Template (A>1)
Open the Basic Template Library that was saved to the project 
inside the Create Template window (File> Open)
Use the folders to locate the right side only (inside the template 
folder) double click on the right side only to make it active

4.1

Using the dynamic settings icon (looks like a compass) from 
the Create Template window set the step to 1 for the x and y
Using the drag and drop method (with backbone only as the 
active template) pull in the different components from the 
component folder to piece together the project typical section

Template Creation

The fuchsia colored box in 
the main window is known 
as the dynamic origin.



About Constraints….
           All points should be based from the top layer points. Keep in mind the shoulder will 
be rotating when superelevation is added
           Constraints are also important for the backfill. Locked in with a vector offset from 
the shoulder and a 1:6 slope from the finished grade shoulder, the width will vary based on
the rotation of the road.
           Vector offset (which keeps the same slope as the two points used as parent points) 
can be used for any case where the slope varies and needs to be matched.
         The color of the points represents the number of constraints on the point
          Point constraints are used to manage the behavior of points in a template.  They are used 
so that if a point is moved in a template, either by the user editing the template or by the 
application of a horizontal or vertical control during design processing (such as superelevation), all
the points related to the point being moved behave in a rational and predictable manner. 

         Because the Edge of Backfill point is determined by the slopes from the template, the only 
thing  required to do is make sure the slope that is set is correct for the project by double clicking 
on the EOB point. Make sure the slope constraint matches the slope to clearzone desired.

Template Creation

4.2

A point can have at most two constraints on it. Then it is considered “fully constrained.” 
A point that is fully constrained is represented by a red plus sign.

A point that is partially constrained, meaning it has only one constraint on it is shown 
with a yellow plus sign.

An unconstrained point is shown with a green plus sign.

The child point has two parent points and will be projected onto the vector 
defined by the two parents. If the offset is not zero, then the child point will 
maintain a perpendicular offset from the parent vector at the specified 
offset value.  Negative values indicate an offset to the left of the vector 
defined by the parent points. Positive values indicate an offset to the right.



Template Creation

With the right side only active select from the
driving lanes the desired pavement 
thicknesses -DOUBLE CLICK TO SET  A 
TEMPLATE ACTIVE, SINGLE CLICK TO 
HIGHLIGHT
Drag the component from the library for the 
driving lane into the main window and place 
it on the dynamic origin point

4.3

Template Creation

Note:  Double clicking on the Right 
side only template will set it active 
(the red square). Whichever 
template is active will be viewed in 
the big window. 
By clicking once on a component or
another template a preveiw will 
appear in the small window on the 
bottom left Preview. This window is 
where the blue square appears, 
allowing the template or component
to be dragged to the active window. 
Be careful as to which template is 
selected as active. 

Repeat this process to place the shoulder, 
backfill, clearzone and end conditions (from the 
centerline of the template –over). Be sure to set
the horizontal constraint on the shoulder 
component EOS point to the desired width for 
the project. Do this by double clicking on the 
EOS point and edit the width on the horizontal 
constraint.
If desired, merge components (careful to get 
right on the line-it may be necessary to use the 
zoom in command)



Next edit the template to match your typical section by
clicking on the active template tab and editing the 
parametric constraints. 

Template Creation

4.4

Double click on the special ditch 
foreslope 1:6.  On the Component 
Properties window set the horizontal and 
vertical alignment to the special ditch 
alignment for this template.

Repeat this process for each special 
ditch foreslope (1:4 and 1:3).

Next check special ditch, ditch, and fill points. These are
pre-set in the seed template library to fit the 1:6 to 4’, 
1:4 to 10’, and 1:3 for greater than 10’ (measured from 
the edge of finished shoulder). If necessary, change the 
vertical constraints on the points and set them to reflect 
the desired vertical depth. Leave the slope constraint on
the points. 
End condition points are edited in the same way the 
template points are edited except they have the end 
condition properties window



Check for Interception- specifies the preceding 
segment will be checked for interception of the 
target when the end-conditions are solved.  If it 
is turned off, then the segment will be ignored 
when checking for interceptions.

Place Point at Interception- specifies that when an 
interception is found along the preceding line 
segment, the line segment will be drawn to the 
interception.  Otherwise, if the interception is 
found, the line segment will be drawn to its 
maximum width.

End Condition is Infinite- specifies the last segment 
will be considered to be of infinite length when 
attempting to intercept the target. This option is 
only applicable to the last point on the end 
condition.

Do Not Construct- specifies the point will be solved 
like all other points in the end-condition, but the 
point will be skipped when drawing the 
component segments.

PRIORITIES
Priorities are set on end condition components
No two end conditions on the same side of the 
template can have the same priority (this 
results in priority conflicts)

The ditch bottom and ditch backslope can be 
part of the same component
Testing end conditions before going on to 
roadway designer can save time and rework

4.5

Template Creation

Select the Test button on the Create Template window. Under Available Targets, select the 
<Active> Surface. Move into the window and move the cursor up and down to see how the end 
conditions perform.



4.6

Template Creation

Once all the end conditions are edited and 
tested, right click on the template folder and 
select New > Template from the drop down 
menu 
Right click on the new template and select 
rename from the drop down menu
Name the template to the name desired to 
appear on the Typical Section sheet. For 
example: TYPICAL NO. 1 STA. 196+00.00 TO 
STA. 212+50.00

Data point  just above the template 
to keep the active surface on 
screen and select under Available 
Targets the special ditch alignment 
and select the Draw button.  Move 
into the window and move the 
cursor up and down to test the 
special ditch end conditions. 

Close the Test End Conditions 
window.

Before pulling in the backbone, set the apply affixes 
command. On the Create Template window Tools> Options

On the Template Options window, turn on Apply
Affixes
Key in the Suffix (space) L for left (space) R for 
right
Select the OK button



4.7

Template Creation
Set TYPICAL NO. 1 active with a double click. Single click on Right Side Only and while dragging
it into the main window of the new template (holding down the left mouse button) right click and 
select mirror from the pull down. Make sure the template origin point is lined up exact with the 
dynamic origin at 0,0. This can be checked looking at the XY on the Dynamic Settings window as
the template is pulled in.

If display point names is turned
on from the display options in 
the top right corner of the 
Create Template window, the 
point names become visible



 
Once all of the left side end 
conditions are adjusted : Select
the test button
First place the existing ground 
in the window just above the 
template.
Highlight the left special ditch 
alignment in the available target
window and select draw to 
place it on the test screen. Then
select the existing surface and 
slide the bar to test the 
conditions

4.8

Template Creation

Right click on the line running 
down the center of the template 
and merge the left and right 
components.
The cursor must be placed 
directly on the component or 
Merge Components will not be 
an option.

 Now that both sides of the template are 
created, set each of the special ditch 
foreslope components to seek the special 
ditch vertical for the left side.  



Viewing the Template in MicroStation

4.9

Template Creation

In Microstation open the Typical.dgn saved to the project. From 
the InRoads task menu Modeler>Create Template (A>1)

Open the template folder 
and right click on the 
template 
Select display from the 
drop down menu
From the display template 
window load the 
preference

From the display template window for Define End Conditions 
select the end conditions that need to display with the 
template. If the incorrect one is selected to deselect just data 
point on the segment again.



Viewing the Template 
in MicroStation

4.10

Template Creation

Once all the appropriate end conditions 
are chosen, select the apply button on the 
Display Template window.  Data point in 
the Microstation screen. Close the display 
template window.

Make adjustments to the text and end condition lengths and rounding as needed. Place the 
Typical Standard Sheet Border from the cell library and scale it. 
Note: The entire template and all the text are a graphic group.  When graphic group is turned 
on they move together.



 CHAPTER 5

   Roadway Designer

Creating a Surface using InRoads Roadway Designer



Notes



        There is also a radial for superelevation 
which creates a fourth window. Within that 
window there is a right click option where 
all of the superelevation commands may 
be accessed. It has more options to 
choose from than the Superelevation 
menu on the top of the Roadway Designer
window.

There are three views in Roadway Designer 
The plan view (upper left corner) The profile 
view (lower left corner) The cross section 
view (on the right side)

To use roadway designer, it is necessary to have:
•A horizontal and vertical alignment or a surface feature that 
defines the location of the new road or object being designed.
•One or more existing surfaces to define the extents of the 
design.
•One or more templates, created with the Create Template 
command, to determine the cross section of the design.

The first task inside Designer is to manage corridors 
(the first icon on the row of designer icons)
This step tells InRoads which horizontal & vertical is 
desired and station limits
In the manage corridors window, name the corridor (this 
will be the name of the surface produced when create 
surface is run). Next set the surface symbology.
In the drop down for Type, select alignment
Set the station limits (by not setting limits, it will default 
to the length of the alignment)
Select the add button to add a corridor to the designer

Roadway Designer

5.1

Profile

Cross 
Section

Plan

Superelevation



 Select template drops to tie the template to the corridor
 From the template drop window select the desired corridor
 Select the station the template should start
 Select the desired interval (this will be the frequency of 

template drops along the alignment. 25 is the standard for 
earthwork purposes)

 Use the folders in the Library Templates to navigate to the 
desired template (notice the template appears in the display 
window when it is selected)

 Select the Add button
 The template drop will appear in the Template drops window
 Multiple Template drops can be made in this window
 To edit the template drop highlight the drop desired to change

from the Current Template Drops (at the bottom of the 
template drops window) make the changes and select the 
change button

 Once a template drop is added and the window is closed, the 
drop shows in all three views of the Roadway designer 
window

The second icon on the designer window is the template drops

If a template is edited from the template library, it will appear red in the template drops box 
until it is selected in the template drop and the synchronize with library button is selected

Roadway Designer

5.2



If there is superelevation on the project, that will be the next step
Select the display superelevation radial at the bottom right hand corner of Designer.  This will 
display all the curves based on the corridor’s horizontal alignment.  A right click in the 
superelevation window will give a pull down menu. Select Create Superelevation Wizard > 
Table…

1

1. For Table, use the ellipses to navigate to the appropriate  table. Select from: 
R:\CADD_Support\Design\InRoads\superelevation

2. Highlight the desired curves and select Load Values From Table.  If the job has more than one 
design speed, this step will be repeated for each speed.

Superelevation Wizard

5.3

2
Right Click here  for this  menu



3

3.    On the top portion ( the sections part) select the add button
4.    Turn on the check box for List all backbone points. Set the Crown Point (for this example: 
centerline. Left range is the edge of driving lane on the left and Right range is the edge of driving 
lane on the right). For pivot direction select From Crown Point. The number of lanes selected will 
depend on the number of lanes rotating. If the project has a runoff multiplication factor, enter it 
(Only if there are more than 4 lanes). Select the okay button once all the information is entered.5

5. Check the information in the Superelevation for Selected Sections to make sure it matches 
the load sheet that was calculated. 

6. On the final window select the finish button.

6
4Superelevation Wizard

5.4



7  7.      If there is an overlap a 
prompt will appear to 
automatically fix with the Fix 
Superelevation Overlap window.  
Select the check box Apply Full 
Super to Full Super Planar 
Transition and then the select the 
Apply button.

OVERLAP

5.5



The create surface icon is the next step in Roadway Designer. 
It is good practice to run through the designer after the 
template drops and make any necessary adjustments to the 
design before creating a surface
Select the icon (hovering over the icon will show it’s name) 
that looks like a slice of green layer cake

On the create surface window:
Key in a name (this will be the name of the new 
surface
Select the default preference
Select empty design surface
Add exterior boundary (set the style to exterior 
boundary)
Triangulate (this will triangulate the new surface once 
it is created)
Select the apply button to create the new surface

The creating surface window will appear
Once it is finished close the Create surface window
The new surface will appear in the surface portion of the 
workspace bar.

5.6

Create Surface



 Creating a surface actually creates a 3d model 
of the design using the typical section designed 
in Create Template and the horizontal & vertical 
alignments

 The features are created from the template 
points and these features determine the 
triangulation.

 The color, level, line weight, and line style of the 
features displayed in the plan view are 
determined by the features’ style.  Components 
work the same way.

 Components are created with the components 
defined in Template Creation and can be used to
show the various pavement thicknesses

 The volumes command in cross sections can 
measure the components.

 The cross sections show the design surfaces 
and the existing surfaces in an actual cross 
section view at the designated stations

 Best practice for designing a surface in inroads 
is to build everything into the model.

 Contractors have the capability to set their 
grading machines from our submitted dtm file. It 
reads the coordinates from each point on the 
feature and grades the road accordingly.

 Never edit the cross sections by hand!

 In version i the ability to model the road 
according to any design has become possible. 

 Although it may require a little extra effort in the 
beginning, building the model correctly can 
actually save a lot of time in the long run.

Isometric view of design triangles

Isometric view of design components

Cross Section views of existing and 
design surfaces

Roadway Designer

Top view of design surface 
features

5.7



Notes



CHAPTER 6

      P&P SHEETS



Notes



Create a new microstaton file using the seed file 
R:\CADD_Support\MicroStation\Seed_Files\ 
Roadway- North or South zone\ Profile. 
Save it in the project folder in the reference folder. It 
will also need to be renamed, such as project number.

 The preferences (xin) must be loaded

Next on the Microstation task from the InRoads 
Commands go to Drafting>Plan & Profile Generator 
(S>T) At the bottom there is a preference box. Load 
the appropriate preference for the job.  This brings in 
settings for the sheets based on scale.

Set the start station to an even station AND turn off the station locks, to get a full first sheet. This
will eliminate a lot of clean up work. Just make sure to turn the station locks back on when finished 
generating P&P sheets.

Main tab- Set the horizontal alignment to the alignment needed for the PnP Sheets. Also set the 
station limits
Plan Controls tab- load the model files.  This will be any file that needs to be attached for the P&P 
Sheets (except the profile which attaches itself).

P&P GENERATOR

6.1



Sheet Layout tab- Set the Host file (Note: this 
“Host file” is just a name and a path. Set the 
path where the PP sheets will go and name the 
P&P sheets as needed for the project-(this file 
does not have to be pre-existing).
Then select the ellipses for the Seed Host File 
(R:\CADD_Support\MicroStation\Seed 
Files\Roadway\ select either North or South 
zone folder- depending on the projection of the 
survey files and choose SeedHostFile.dgn).

Profile Controls tab- select the existing surface 
The box that has the X in it represents the surface
that will be displayed in the profile and that will 
automatically attach to the P&P sheets.  
The surface that is highlighted will control the 
window shift.  These do not have to be the same 
surface.

P&P GENERATOR

6.3



Border and Title tab- set the user 
text 1 and user text 3. Be sure to 
use the tab key to enter them 
once they have been typed them 
in.
Click Apply and data point in the 
profile.dgn  to generate sheets. It is 
normal for this process to take a few
minutes.

InRoads will create separate files for 
each P&P Sheet, attach the P&P 
border, the North Arrow, the profile, 
and all the reference files (defined in 
model files)

P&P GENERATOR

6.4



Annotation for the Horizontal Alignment

BEARINGS 

Geometry>View Geometry>View Horizontal 
Annotation (E>1>3)

-Key in the Horizontal Alignment or use the 
target button to select the alignment 
from the Microstation display

-Click the Apply button

ALIGNMENT view the alignment (right click on the 
alignment from the workspace bar and select View 
from the pull down)

STATIONING 
Geometry>View Geometry>Stationing 
(E>1>6)
BE SURE TO SELECT THE 
APPROPRIATE PREFERENCE from 
the View station window. Select the 
Apply button. 

Open the seed file JPNAlign01 that has been named for the project and saved to projects folder.

6.5

Horizontal Annotation



Annotation for the Horizontal Alignment

CURVE DATA 
Geometry>View Geometry>Curve Set 
Annotation (E>1>3)
Under the main tab set the alignment
Click the Apply button then hit close on the 
curve set annotation window

The curve data, bearings, and stationing are all automated information stored in InRoads 
and can be viewed.

6.6

Horizontal Annotation



Annotation for the Vertical Alignment

Geometry>View Geometry>Vertical Annotation (E>1>4)

Select the Preference button from the View Vertical 
Annotation window. Choose the appropriate preference for 
the alignment annotation Select the Apply button and close 
the view vertical annotation window

6.7

Vertical Annotation

Open the profile attached to the P&P Sheet

On the InRoads menu highlight the vertical and 
right click> select view from the pull down

Turn on the delete ink lock!



Annotation for the Vertical Alignment

Annotation for Profile Finished Grades

Make sure the desired profile set
is active (in the pull down for 
profile set select the appropriate 
profile)

6.8

Vertical Annotation

Load the finished grade preferences from the 
preference button on the Annotate Profile 
Window. Under General select: 

the vertical
surface
corridor
Interval
station limits

In the profile window select the profile(s) to 
annotate
Select the apply button

Evaluation>Profile>Annotate Profile(T>1>2)



Using the Generator to Create Erosion Control Detail Sheets

 P&P GENERATOR for Erosion Control Detail Sheets

 LOAD TWO SEED FILES FROM THE R DRIVE. These can be created using the seed files from the R 
drive or copied to the machine from the R drive.

 Erosion Control.dgn

 SeedHostFile.dgn

 LOAD THE PREFERENCES FROM THE R DRIVE THAT HAS BEEN SAVED TO THE MACHINE. 

 Now all the files are ready, to start in the Erosion control.dgn. Note: an ALG is required. Set the global 
scale factor for the text.

 To avoid sheet mess ups extend the horizontal alignment to an even station (back to the nearest 500’) 
and turn off the station locks.  This forces the first sheet to be a full sheet, making less to fix. 

 Inside Generator:

 MAIN TAB

  1.   Load the preference (Erosion Control) 

  2.   Set the alignment.

  3.    Set the station limits

 PLAN CONTROLS TAB

 Use the browse button to load the model files. This is any sheet that will be attached to the EC Detail 
Sheets 

 SHEET LAYOUT TAB

 Set the host file (select the browse button and set the path and name the file for the job-this file can be 
created right  here and it needs to be named different than the file currently being worked in. it can’t be 
Erosion Control.dgn)

 Set the seed host file (SeedHostFile.dgn)

 BORDER AND TITLE TAB

 Set the user text 1 (use the tab key to enter after it has been typed it in)

 Set the user text 3 (again use the tab key to enter)

 CLICK APPLY

Note: if creating all sheets in one, the reference files will have to be moved.  Select all the even numbered 
reference files and move them  to the desired location along with every other sheet border cell. To avoid this 
moving, build the sheets using single each sheet from the sheet layout tab Host file content radial on the Plan 
and Profile Generator window.

Note:  Things to show in Erosion Control Detail Sheets-

Alignment & Stationing Toes

Right of Way Drives

All Structures Paved and Special Ditches

New Road A Key for EC items

Everything else can be turned off.

P&P GENERATOR

6.9



CHAPTER 7

     Cross Sections 



Notes



Create a new Microstation file using the seed file from the R 
drive (in R:\CADD_Support\ MicroStation\ 
Seed_Files\Roadway) named JPNXSec01 and save to the 
project folder.
Note: view the horizontal alignment to make sure the sections 
don’t overlap the alignment
On the InRoads menu select Evaluation>Cross 
Section>Create Cross Section (T>2>1)

On the Controls folder choose the 
Limits subfolder and turn on the 
check box for Station. Set the 
station limits for the sections.

Click the apply button and select a spot on the 
MicroStation screen away from the horizontal 
alignment

Cross Sections Creation

7.1

Select the General subfolder and select the desired surfaces
Select the Source subfolder and select the alignment from the drop down menu



Before completing any work on the cross section set, the earthwork should be compared to make 
sure each of the surfaces to be labeled with the end area volumes are within 2% of the triangle 
volume calculations. 

Cross Sections Creation

7.2

On the cross section window 
select the folder for End-Area 
Volumes. Choose the surfaces to 
be calculated. Select the Apply 
button.

From the report browser, 
choose the 
EndAreaVolume.xsl.  At the 
bottom of the report, the total 
cut is shown on the right and 
total fill on the left. Save the 
report or record these 
numbers the totals are in 
cubic yards.

From the Inroads commands select 
Evaluation>Volumes>Triangle Volumes 
(1>T>3). On the Triangle Volume window set
the Original surface (existing ground) and 
Design surface- these must be the same 
surfaces selected on the EndAreaVolumes 
command. Select the Add button so the 
surfaces appear in the main box and Apply.



Cross Sections Creation

7.3

From the report browser, choose the TriangleVolume.xsl.  At the bottom of the report, the total 
cut and total fill are shown in cubic yards. Save the report or record these numbers.
The end area volumes must be within 2% of the triangle volumes. Divide the end area volumes 
by the triangle volumes. If this number is more than 1.02 or less than 0.98, add event points or 
cut the sections closer together to get it within 2%.

��� ���� �������
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 = ? ( where ? must be < 1.02 and > 

0.98)



Gather all Roadway information and files required to make a set of Cross Sections.
 
Acquire the following information from Bridge:

Begin Bridge Station
End Bridge Station
Subgrade Intercept Stations (Known to Roadway as Last Full Stations)

 
Load InRoads and all necessary files to create a profile and a set of Cross Sections.
 
Create a profile drawing.
 
Locate the Subgrade Intercept Station (Last full station) on the profile.
 
Project a 1:3  (1’ vertical to 3’ horizontal) line on the profile.  The line should begin on the 
subgrade at 
the Subgrade Intercept Station (Last Full Station) and extend at a 1:3 slope until it intersects with
the existing ground.  (See illustration below.)  
 
Caution:  The horizontal and vertical scales may not be equivalent.  Make sure the 1:3 projected 
line (slope) matches the appropriate scale for the plan and profile sheet being used.
 
Notes: 
Bridge may carry the dirt included in this area on occasions.  (For instance in a ditch or channel 
realignment.)  When Bridge carries the dirt, it is normally determined early in the planning 
process (such as in a Plan-in-Hand.)  

Mostly written by: Terrie Troupe

Custom Cross Sections

7.4



Trim the projected 1:3 lines to the lowest point on the channel bed if 
the lines do not intersect with the existing ground. (Example right)

Determine the Stations where the projected 1:3 slope intersects with 
the existing ground.  Roadway describes this as the Zero Station.  If the 
projected line does not intersect with the existing ground, use the lowest 
point of the channel.   (Example right) 

All prerequisite data should be gathered at this point and a custom set 
of Cross Sections can now be created.  The initial set up to creating a 
Custom Set of Cross Sections is the same as a normal set.  

Open the Create Cross Section tool.   
Select General and choose the desired surfaces.  
Select Source and choose an alignment to run the Cross Sections on. 
Select Custom and choose and/or set the necessary items

The option Station Range will be used to create Custom Cross Sections for Bridge Exceptions. 
Using a station range will produce multiple cross sections perpendicular to the alignment.  The 
span duration will be defined by the stations specified in the start and end station boxes.   Note:  
The stations used in Custom will over ride the stations limits defined in Controls. 

Custom Cross Sections
Mostly written by: Terrie Troupe

7.5



Mostly written by: Terrie Troupe

The Type Perpendicular will also be used to create a custom set of cross sections.  
Perpendicular option will create a single cross section perpendicular to the alignment.

Custom Steps: 
Set the Preferences as needed for the project.
Set the Type to Station Range.
Enter the Start Station for the Project.
Enter the first Full Station for the End Station.
Edit the Intervals and offsets if needed for the project.
Press the Add button.  This action will create a range of cross sections from
the beginning station to the full station.
Set the Type to Perpendicular.
Enter the first Zero Station.
Edit the offsets if needed for the project. 
Press the Add button.  This action will result with a single cross section cut 
perpendicular to the alignment at the specified station.
Set the Type to Perpendicular.
Enter the second Zero Station.
Edit the offsets if needed for the project.
Press the Add button.
Set the Type back to Station Range.
Enter the second full station for the start station.
Enter the end of project station for the End Station.
Edit the Intervals and offsets if needed for the project.
Press the Add button.  

Custom Cross Sections
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The Custom dialog box should now reflect the first station  that was entered each time the 
Add button was pressed as well as the Type of Cross Sections to be created for that entry.  
(Example upper right) Repeat the steps for additional bridges if applicable. The Update, Save, 
and Save As buttons can be used if desired.  Saving and Updating allows for quick editing when 
changes occur and cross sections may need to be rerun. If no other special situations need to be 
addressed, press the apply button and place a set of cross sections .  The cross sections should 
reflect the data entered in the Custom dialog box. Stations run from the beginning station to the 
first full station.  Then skip to the two zero stations.  Conclude with the second full station and 
continue with the normal intervals to the end of project.



Before the features can be annotated, they must be viewed in the cross sections…
In Update cross sections Evaluation>Cross Section>Cross Sections (T>2>1)

Select the Update Cross Section folder
Highlight Crossing Features sub-folder
Select the surface
Select the feature
Click apply 
Note: most features show up as a symbol.  The centerline should show
up as the CRL.  This would depend upon the style tied to that feature.

Ditch Bottom Feature

CL Feature

Cross Sections Annotation
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Cross Sections Annotation
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Evaluation>Cross Section> 
Cross Sections.(T>2>1) Select 
the  Annotate Cross Sections 
folder. Under the General sub-
folder select the surface  the 
feature to be annotated is in. To 
limit the stations the annotation 
is displayed  turn on the Limits 
by selecting the check box next 
to Station Range and set a 
range of stations to display the 
annotation.

Choose the Preference button at the 
bottom and pick the desired 
preference for what annotation is 
needed. For example to annotate 
finished grade elevations,  load the 
preference Finished Grades. 

This preference will determine how 
the annotation is displayed for each 
item.

Make sure the delete ink lock is turned off when using the annotation command.



On the Cross Sections window, under the
Annotate Cross Sections folder go to the 
Features folder  and select  the Annotate 
subfolder  then highlight the desired 
feature. For finished grades this would be
the CL feature. Click Apply.

Cross Sections Annotation
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Next highlight the ditch bottom 
features and select the preference 
button.  Choose the desired 
preference for ditch bottom and 
select the load button. Close the 
preference window and select the 
Apply button on the Cross Sections 
window to annotate the selected 
ditch bottoms.



Cross Sections Annotation
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If the preference selected was the 
left side only (or right side only) 
preference for the ditch bottom, 
repeat the process to annotate the 
other side. 

Once annotation is complete, select
the Update Cross Section folder  
from the Cross Sections window 
and choose Crossing Features.  
Set the mode to Display Off and 
highlight the surface from the 
Surface box and select all of the 
ditch bottom features. Select the 
Apply button.



In Microstation, open the file that 
contains the items needed in the drape.
From the InRoads task menu, select the 
File>Import>Surface Advanced 
(Q>9>2).

Cross Sections Draping
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On the Import Surface Advanced window first set the 
intercept surface (this will be the surface the 
elevations will come from-usually the existing ground).
Next  for surface, key in the name of the new surface 
(example: Draping) or select the that the features will 
go into.
Select the Apply button and close the Import Surface 
Advanced window.



To check draping, select from the InRoads task menu Surface>Feature>Feature 
Properties(W>7>1)
On the Feature Properties window, scroll through the features and make sure all of the elements 
from the dgn file imported successfully.

Cross Sections Draping
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If any of the items are missing, it may be the selection criteria in the import surface advanced 
command.  The selection criteria will have to be changed so that the element will be selected on 
import.  Once the rule is adjusted, empty the Draping surface and repeat the import process.  
Items in the dgn file that use by level symbology will not be recognized.  If changes were made to 
any by level symbology  properties to the actual linestyle before importing, most of the criteria is 
searching for linestyle so that should solve most cases.  There are some items which search for 
specific levels instead of the linestyle.



If there were items in the file that did not 
become features when using the Import 
Surface Advanced command, check the rules 
for that particular item.  For example, if 
drapeing the existing utilities from the Topo file 
by following the steps from the previous page, 
the Tug lines did not come in as features but 
the rest of the items did, check the rule for 
Tuglines.

File>Import>Surface Advanced (Q>9>2).  
Locate Tuglines listed in the Rules box.  
Double click to open the Edit for that rule.

On the Edit Import Rule 
window, select the Selection 
Criteria folder.

  Cross Sections Draping
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Notice the Element is filtered by LineStyle. To test if it is read the file’s linestyle, select the 
“Highlight Matching Elements” button.  If the element does not highlight then add the elements 
linestyle to the selection criteria.  This can be done by selecting the Line Styles subfolder and  
locating the style from the Available list and selecting the Add> button to add it to the Selected 
list. 

Multiple line styles may be added. 
Also, selecting other “Filter 
Elements By” items such as Level 
and add the level the selected 
item is on. When finished adding, 
select the apply button to save the
changes.  The changes will be 
stored in the .xin file.  Notify 
Automation and Graphics if a 
linestyle should be permanently 
added to the master preference 
file.

  Cross Sections Draping
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Note:  Keep in mind that any elements matching the criteria here will be imported.



        Next, use the update cross section command 
to view the new draped features in the cross 
sections. 
Evaluation>Cross Section>Cross Sections 
(T>2>1)

    

  Cross Sections Draping
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        From the Cross Sections window, 
select the Update Cross Sections 
folder. Set the desired cross 
section set. Select the Crossing 
Features subfolder.  Highlight the 
desired Surface from the surface 
box.  Next highlight the desired 
features from the feature box (to 
select all right click in the Feature 
window and choose Select All). 
Select the Apply button then close
the Cross Section window.



Locate the crossing utilities from the existing topography file.  Place a cell close to the alignment 
where the utility is located using the place cell command in MicroStation.  Import the crossing utility
from the inroads menu select:  File>Import>Surface (Q>9>1)
Set the surface to the one the feature will be located in                                
Load from single element
Elevations: Drape Surface
Intercept Surface: the existing ground surface
Key in the Seed Name
Set the style to Utility Tugline Crossing
Point type for crossing utilities will be Random
Be sure to turn on exclude from triangulation
Click the apply button and select the cell placed on the utility

Update the cross sections to show the new 
features.
Select Evaluation>Cross Section>Cross 
Sections>Update Cross Sections   (T>2>1)
Make sure the mode is set to display on
Select the sub-folder for projected features
Select the Surface the utility features are in
Select the feature from the feature list 
Click the Apply button              
                    

Evaluation>Cross Section>Cross Sections>Annotate Cross Section (T>2>1)
Load the preference (from the bottom of the Annotate Cross Section window) named Xing Utilities 
Label
On the General folder select the surface the feature is in
On the Features folder select the sub-folder Annotate and select the crossing utility feature that 
needs to be annotated
Select the Apply button on the Annotate Cross Section window
                                                                                   

          Drape & Label Crossing Utilities
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Use the template library to create a specific pavement removal template.

Pavement Removal
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First be sure that to begin IN A 3d MICROSTATION file. From the InRoads commands select 
Surface>View Surface>Features (W>1>5).  Set the surface to the existing dtm from survey. 
Using the filter button, set the filter to existing asphalt and centerline (The filter can be set from the 
View Features command by selecting filter from the InRoads Surface tasks). Make sure the Filter 
Lock is turned on from the Locks toolbar. View the existing asphalt features. Using the Microstation
tool Element Selection, select the centerline of pavement . 

FILTER 
LOCK

Pavement Removal
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Select from the InRoads tasks 
File>Import>Geometry (Q>9>3).  Select the Type 
Horizontal and Vertical Alignment from the Import 
Geometry window then key in the name for the 
Center of existing pavement. Select the Style. Make
sure the check box for All Selected Elements Added
to Single Alignment is on and Apply. 

Repeat this process for the left and right pavement 
edges using the Microstation command Element 
Selection to select each one individually.  Be sure to
delete or deselect the previous feature string for 
each.

Pavement Removal
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InRoads Modeler Task>Roadway Designer. Create a new corridor(s) for pavement removal (the 
reason for this is because if there is more than one removal area then more then one corridor is 
required).
WHATEVER ALIGNMENT CHOOSEN TO BE USED TO CREATE THE CROSS SECTIONS WILL 
BE THE ALIGNMENT THE CORRIDOR IS BUILT ON. If the cross sections are created on the 
A001 alignment, the corridor will be created using A001. 
Note: Point controls will be used to move the template to the center of pavement alignment 
(created in previous step).

Pavement Removal
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Add a template drop for the Pavement Removal Template. Make the interval 25 
for removal.

89

Use point controls to control the CL, 
LEP and REP points with the new 
alignments created from the existing 
pavement features for the extent of 
the removal.

Pavement Removal
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BEFORE GOING ANY FURTHER, TURN OFF THE 
FEATURE FILTER LOCK!!!!!!!!!!

To load the locks toolbar, select Tools from the Microstation Main
Menu and turn on the check box for InRoads Tools Locks from 
the Tool Boxes window.

Pavement Removal
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Create the surface for the pavement removal. This surface will then be merged with the existing 
surface from survey using the Merge Surface command (Surface>Edit Surface> Merge Surfaces).

Repeat all the steps that created the first run removal surface for any other removal on 
the project. Create the other surface and merge it with the merge surface created in the 
first step.  Do these steps as many times as necessary, each time selecting as the 
original surface the merge surface before it.

On the Merge Surfaces window the 
Original surface will be the surface that 
was there first.  For Design set the pull 
down to the surface that was created 
called Remove pavement.  The 
destination surface is a surface that can 
be created from this window by keying in 
the new name.

Pavement Removal
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Pavement Removal
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Evaluation>Cross Section>Cross Sections(T>2>1). 
Update Cross Section folder select the Display On 
radial. In the Surfaces subfolder  for Surface highlight 
the new Existing with Removal and select the Apply 
button.

Change the radial to Display Off 
and for Surface highlight the old 
existing ground and Apply.  

The removed pavement can be seen 
in the cross sections (within the station
limits of the removal).



End Area Volumes
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Evaluation>Cross Section>Cross Sections 
(T>2>1).  From the Cross Sections window, select
the preference button and choose the desired 
preference and hit the Load button then close the 
Preferences window. Next if there is more than 
one phase of earthwork on the Inroads menu 
select from the locks toolbar and turn off the delete
ink lock. 

From the Cross Sections window select the  End-Area Volumes folder. Select the preference 
button and choose the desired preference and hit the Load button then close the Preferences 
window.
Under the General subfolder check the surfaces to compare. If desired, for Limits turn on the 
Station Range check box and set the stations.

Note: If the locks toolbar does not appear, choose from the Microstation main menu 
Tools>Toolboxes and turn on InRoads Tools Locks.

Note: for the type, one must be existing and one design.  Type is set on the main tab in the surface
properties command.. If it needs to be changed, then it must be updated in the cross sections or 
inroads will not recognize it.
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If there are volume exception(s), on the 
Cross Sections window choose the 
subfolder Volume Exceptions. For 
Settings, choose the Start and Stop 
Stations for the exception. Choose the 
Add button so that the stations appear 
in the Volume exceptions box.

End Area Volumes

If there are multiple phases on the project 
turn off the delete ink lock before running the 
next phase.

In Microstation select the level manager
and turn on the desired phase level for 
the project.



To create the report for balancing the 
earthwork FIRST LOAD THE 
PREFERENCE Fill Factor

Cross Sections
End Area Volumes
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Select the Compaction/Expansion subfolder. 
For Settings select the Start and Stop 
Stations. Key in the desired amount in the Fill 
Factor box. Select the Add button so that the 
stations appear in the Compaction/Expansion 
box.

Select the Apply button.
Save the report to the project folder.

Note: if the style 
sheet is not set 
there will be a 
message asking for 
a style sheet default 
for End Area 
Volume Reports.  
The style sheet 
default can be set 
with a right click on 
the style sheet



 

Crossing

if checked, elements in the Storm and Sanitary database of a valid type are displayed if they fall within the Left and Right Offsets and within the 
Ahead and Back Bands for each entry. Valid crossing types are pipes, culverts, channels and utilities. 

The Storm & Sanitary element must have the Surface Feature style > Settings > Cross Section Display > Crossing Points toggled on.

Projected

if checked, Storm and Sanitary elements that fall within the Left and Right Offsets and within the Ahead and Back Bands for each entry are 
displayed. Valid types are all Storm and Sanitary elements except zones and areas. The Storm & Sanitary element must have the 
Surface Feature style > Settings > Cross Section Display > Projected Points or Projected Line Segments Points toggled on.

 

If the inlet or manhole's center style has a cell specified in its cross section point symbology and the inlet or manhole has a top height greater 
than 0.0 the top of the vault is clipped the top height amount and a cell is placed that represents the vault top.

Ahead Band

specifies which elements or parts of elements are projected to a section. A band is formed by the constraints of the Left and Right cross section
offsets and the Ahead and Back bands.

Back Band

specifies which elements or parts of elements are projected to a section. A band is formed by the constraints of the Left and Right cross section
offsets and the Ahead an Back bands.

Add

adds a cross section definition to the Station/Type list.

Update

updates the cross section definition that is selected in the Station/Type list.

When multiple items are selected only the crossing and projected toggles and corresponding bands are updated. Not available for the Details 
section of this dialog when multiple items are selected.

Graphics

adds the graphics in the current selection set as a cross section definition. A cross section is cut along each graphic in the selection set.  The 
selection set of graphics  can be made without exiting the Cross Section dialog box. If the Add Graphics button does not become active 
after defining the selection set, be sure to select Linestring for the Type.

Import

loads an existing set of custom cross sections. Replaces previous version Open and Browse buttons.

Save

saves the currently open file.

 

When saving a custom list that contains Storm and Sanitary entries, the structure IDs are saved to the file instead of Station/Offset or XY 
locations. This allows the structure locations to change and the same custom file be used without updating the file.

Save As

saves the currently open file.

Apply

executes the command using the information defined in the dialog box. The dialog box remains active after clicking Apply.

Preferences

displays the Preferences dialog box. This dialog box saves the current dialog box settings. These settings can then be loaded at a later time.

Close

dismisses the dialog box and exits the command. The information that has been entered in the dialog box is displayed the next timethe 
command is used.

Help

displays help.

Storm and Sanitary Structures
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       On the first cross section, key in the county name, JP number, and the sheet number. 
Power select the county name and JP number. Use the array command.

Set the number of columns to the number of sheets.
Set the column spacing to the distance between cross section 
sheets (390.0017 for regular size cross sections)
Follow the MicroStation prompts on the lower left hand corner of 
the screen.

To number the sheets, use the copy increment text command.

Select the sheet number and in the key in window key in di=390.0017,0
This gives the distance to copy horizontally and vertically. 
The rest of the key in determines how many numbers will be copyed.
From the computer keyboard select  shift + pipe  then  key in the number of sheets.

Label the Cross Section Block in MicroStation
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 Next TURN OFF ACCUDRAW  !!!!!!!  AccuDraw will cause the text to overlap



To create a Mass Diagram the 
same file the cross sections 
reside in must be open. Go into 
the cross section file and on the 
Microstation main menu select 
File> Save As. Name the file 
Mass Diagram.

Mass Diagram
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From the inroads commands 
select Evaluation>Cross 
Section>Cross 
Sections(T>2>1). Make sure 
to select the correct Cross 
Section Set from the pull 
down.

Choose the End Area 
Volumes folder and turn on the
check boxes for the two 
surfaces that need to be 
compared.

Select the preference button and highlight the Mass 1:1 
preference and select load. Close the Preferences 
window.



Mass Diagram
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Select the Compaction/Expansion 
subfolder. For Settings select the Start 
and Stop Stations. Key in the desired 
amount in the Fill Factor box. Select the 
Add button so that the stations appear in 
the Compaction/Expansion box.

If there are volume exception(s), on the 
Cross Sections window choose the 
subfolder Volume Exceptions. For 
Settings, choose the Start and Stop 
Stations for the exception. Choose the 
Add button so that the stations appear 
in the Volume exceptions box.

Select the Apply button on the Cross 
Sections window and data point 
somewhere above the cross section set 
to place the new 1:1 mass diagram.



Mass Diagram
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Next from the Microstation menu 
choose Element> Cells.  On the Cell 
Library window navigate to the Mass 
Diagram Sheet Border and select the 
Placement button to make it the active 
placement cell. 

From the Microstation Drawing commands, select 
Place Active Cell (S>1). From the Place Active Cell 
window set the X and Y Scale to 1. 

Data point in the Microstation screen to place the sheet border.  Do not change the scale of
the sheet border because the text size is set based on the size of this border.  Use the chart
on the next page to adjust the mass to fit the border.



Mass Diagram
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To make the Mass wider or narrower change the Horizontal Exaggeration.  To make the
Mass taller or shorter change the Vertical Exaggeration.

Horizontal Exaggeration =

Vertical Exaggeration =

0.01 = 10000.00

0.02 = 5000.00

0.025 = 4000.00

0.04 = 2500.00

0.05 = 2000.00

0.0666667 = 1500.00

0.08 = 1250.00

0.0869562 = 1150.00

0.10 = 1000.00

0.20 = 500.00

0.25 = 400.00

0.40 = 250.00

0.50 = 200.00

0.67 = 150.00

0.80 = 125.00

0.87 = 115.00

1.00 = 100.00

1.25 = 80.00

1.3333333 = 75.00

1.6666670 = 60.00

2.00 = 50.00

2.2222222 = 45.00

2.50 = 40.00

2.8571429 = 35.00

3.3333333 = 30.00

Formula if you have an exaggeration that you prefer:

100/(Exaggeration)=Spacing  OR

100/(Spacing)=Exaggeration

Left & Right Spacing

Bottom Spacing

Mass Haul Line Grid Information



Mass Diagram
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To change the Vertical 
Exaggeration find the number in 
the chart. On the Cross Sections 
window select the Mass Haul 
Diagram folder.  Key in the new 
Vertical Exaggeration from the 
chart. Hit the tab key on the 
keyboard to accept the change. 

When changing the vertical 
Exaggeration, the Left and Right 
spacing will also need to be 
adjusted according to the chart.  
Select the Left Axis subfolder 
and set the Spacing. Hit the Tab 
key to accept the change.

Select the Right Axis 
subfolder and set the Spacing.
Hit the Tab key to accept the 
change.



Mass Diagram
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To change the Horizontal 
Exaggeration find the number in 
the chart. On the Cross Sections 
window select the Mass Haul 
Diagram folder.  Key in the new 
Horizontal  Exaggeration from the 
chart. Hit the tab key on the 
keyboard to accept the change. 

When changing the Horizontal 
Exaggeration, the Bottom Spacing 
will also need to be adjusted 
according to the chart.  Select the 
Bottom Axis subfolder and set the 
Spacing. Hit the Tab key on the 
keyboard to accept the change.

Data point in the MicroStation screen to 
place the new mass diagram.  With 
graphic groups turned on use the 
MicroStation task menu move command 
(3-2) and move the new mass into the 
mass sheet border. If it does not fit or if 
there isn’t enough room, make a new 
mass with a different exaggeration using 
the chart on page 7-31 for exaggeration 
numbers and spacing.



Mass Diagram
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Finish the Mass with the balance lines, arrows and feathers.  Label Excess Excavation and 
Unclassified Borrow.  Place the Summary grid on the sheet or add another border and place it on a 
separate sheet.  Add sheet estimates and notes.



Microstation File > Print Organizer

Print ORGANIZER
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On the Print Organizer window, 
select File > Add Files to Set

On the Create Print Definition window, select the  Add button. On the Select Files window, 
navigate to the project folder where the print files will be added. Use the control button to select 
more than one at a time within the same folder.  Select the Done button to add the files to the set.  
Select the Add button again if more files are needed from another folder. 

On the Create Print Definitions window,  click on the magnifying glass for the Print Style name.
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From the Apply Print Style window, select the desired print 
style.  To automatically find the shape on level Plot Shape 
Half (or Full)  select a print style with Shape in the name. 
Once the desired Print Style is selected, choose the OK 
button.

Select the OK button on the Create 
Print Definitions window.

Close the Print Organizer.
Note: To change the print styles, all 
files within the set must be changed 
to the new print style.

Print ORGANIZER

On the Print Organizer select File > 
Save As.  Set the path and key in a 
name for the print set (for example 
17458 Woods Half size RDYMFD03) 
and save the new print set.



CHAPTER 8 

   Storm & Sanitary



Notes



Before using Storm and Sanitary, the program must be made 
available inside InRoads.  It is a product add in.  Go to the 
InRoads Tools>Product Add-Ins (F>R)

From the Product Add-Ins window, select the Bentley InRoads Storm 
and Sanitary.  Also turn on the Persist Product Add-Ins on Exit check
box at the bottom of the window.

8.1

Storm and Sanitary



        Before starting, make sure the ODOT_imp_structures.dat file is loaded in the project defaults 
(R:\CADD_Support\Design\InRoads\Storm & Sanitary). This file will give the standard sizes from 
our Roadway standards for structures. 

Next create a drainage data base (.sdb) for the project. Right click on the bottom of the workspace 
bar and select Drainage from the pop up.  On the Drainage workspace right click on Drainage and 
select New from the pop up. Use the New window to name the drainage database.

Storm and Sanitary
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To put in the existing structures, view the features from 
the existing .dtm and locate the first existing structure 
needed in the database.

8.3

Storm and Sanitary 



In the Inroads commands select Drainage>Lay out 
(R>2)

To get back the InRoads Explorer right click on the 
Microstation Screen and hold.  From the popup select 
Explorer Show\Hide.  Dock the workspace bar back on the 
InRoads Explorer Menu.

8.4

Drainage Layout command



For the Pipe ID: key in the station and partial description. For example: 
1090+72.08 EXISTING 24”x51.6’

Use the target button to locate  the northing and easting on each end of the 
structure (from the features displayed from the existing dtm). The 
upstream would be the side with the highest elevation. The existing 
structure elevations are listed in the structure notes in the survey file.

Key in the elevations.

 Note: if the radial is toggled, it will lock the elevation.

After the Apply button is selected the structure can be located in the drainage 
database on the inroads menu. Right click on the structure to edit the 
size, set the symbology and add the details. For User Data in the 
Description key in the rest of the structure details i.e.: RDY RCP 26.5’ 
LT & 25.1’ RT

Drainage Layout
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For existing structures use the 
Existing folder from the Sections 
folder. Select the note needed and 
click apply.  In Microstation click on 
the structure in the cross sections 
and  single click to place the note.

Make sure the notes.dft file is loaded in the 
project defaults

Place Cross Section Notes
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To view the structures in the cross sections, open the Update Cross Section folder on
the Cross Section window. Set the desired cross section set. Select Storm and 
Sanitary. Select from the Projected window all the structures that need to be 
viewed(or right click to select all).  Select the apply button.

Note:  If there are not event points for all the structures, it may be necessary to set 
the Bandwidth ahead and back to be able to see all the structures.

View S&S in Cross Sections
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Plan, Profile and Cross Section Views of the existing 
structure using Storm & Sanitary and the Place Plan 
Notes command

8.8



To create new structures in Storm & Sanitary, view the ditch features in the plan view of a 2d file.
Place a line in microstation where center of the structure will be located.
InRoads reads the X and Y from the line when it is snapped to using the target buttons for structure
location

On the Inroads menu select Drainage>Lay Out (R>2)
Select the Options button to set the size of the structure
Set the shape and size from the pull down menus
Select the apply button
Name the structure in the Pipe ID window (use the structure 
number)
Select the target button beside the easting and northing for the 
upstream
Snap on the high side of the structure 
Repeat this step for the downstream side
Key in the Invert In (flowline in) and the Invert Out (flowline out) 
elevations.

S&S
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   The drainage structures placed with Storm & Sanitary 
can be viewed in the plan (much like features)

     Drainage>Drainage View>Drainage (R>1>1)  Select
the items that need to be displayed (there are 
preferences here too). Select the apply button. 
They may also be annotated with Drafting> Place 
Plan Note.

To view the structures in the Profile, Go to the Evaluation> Profile >Create Profile command
Load the preference named SnS
Select the Source folder and key in the desired structure name under network in both the From and
To box
Be sure existing profile is selected under drainage network reference
Select the apply button and click inside the desired profile
The structure will appear
The structures can be annotated using Drafting>Place Profile Note

S & S in the Plan and Profile
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To view the structures in the cross sections, use
the update cross sections command

Select the Storm & Sanitary folder and highlight 
the structures desired to view

Select the apply button
Once the structure is viewed, it can be 

annotated with place cross section note 
command (under drafting)

8.11

S & S in the Cross Sections





CHAPTER 9

     Quantity Manager



 Before using the pay items, they must
have a formula attached

 Quantities> Quantity Formula 
Manager

 There are already many formulas 
created, but it is possible job specific 
items and change formulas to fit the 
current project

 Formulas are based on different types
of measurement

 Once the formula is tied to the pay 
item, and the pay item to the feature- 
it reads the information for the 
measurement in the formula from the 
feature. Once the formula has been created, tie the formula to the 

corresponding pay item.
Quantities> Pay Item Manager
The pay items are sorted in folders by number
Select the pay item to change from the list
In the formula drop down, select the desired formula.
Repeat these steps for each pay item used.

Quantities: formulas to pay items

9.1



 Create a surface to place the summary 
features in.

 File>new>surface

 Type is design

 Give it a name

 Save the new surface to the project folder

 It is best to use a 2d file for importing the 
summary features

“AREA” MEASUREMENT
To add area features:
Go to surface>view surface>features (W>1>5)
View the features from the design surface to 
create shapes for measuring areas.
It is suggested to view one part at a time to 
simplify
For example: view the left and right edge of 
pavement
Using MicroStation commands, draw lines at 
each end to close the shape.

Once the shape is closed: Quantities>Shapes 
Tool (D>4)
Select the radial Fill
Set the surface to summary (the surface 
needing the feature) 
Set the duplicate names radial to rename
Turn on the exclude from triangulation
Click the apply button
Select inside the shape and be sure to accept it
Once accepted it will add the new driving lane 
feature to the summary surface as a closed 
shape 
Now repeat the same steps to add each shape 
to the summary surface starting with the view 
features command
It is necessary  to repeat these steps for ALL 
the features that need an area measurement 
View features
Close the shape
Use the shapes tool to import the features to 
the summary surface 

Quantities
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“LINEAR” MEASUREMENT
  After the area shapes are all entered, 

enter the linear items.
 Again it is best to be in a 2d drawing to 

place lines.
 Use MicroStation commands to place the 

line at the correct length.
 Use the File>Import>Surface (Q>9>1) 

command to import the line as a 
breakline.

 For example to add a paved ditch to 
summary surface:
 Set the surface to summary
 Load from single element
 Elevations set to use element 

elevations
 Give the seed name
 Set the point type to breakline
 Exclude from triangulation is turned

on
Now repeat the same steps to add each linear 
item to the summary surface

“EACH” MEASUREMENT
 After the area shapes and linear items are all 
entered, enter the “each” items
Use MicroStation commands to place a cell in the 
desired location
Use the File>Import>Surface (Q>9>1) command to 
import the cell as a random point.
For example to add a temporary sediment filter to 
summary surface:

Set the surface to summary
Load from single element
Elevations set to use element elevations
Give the seed name
Set the desired feature style
Set the point type to random
Exclude from triangulation is turned on

Now repeat the same steps to add all the “each” 
items to the summary surface

Quantities
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 Once all of the features are created, the pay 
items need to be tied to the features.

 Surface>feature>feature properties (R>7>1) 

 Use the pay item icon to locate the pay item 
that will be added to the feature.

 Highlight the pay item and select the add 
button to add as many pay items as 
necessary for each feature

 Once the pay items are attached, be sure to 
apply on the feature properties window.

 After all the pay items are attached to the 
features, save the summary surface.

After all the pay items are tied to the features, Quantities> Compute
Quantities (D>3)
Under the main tab,

select the alignment
Mode to all (or fence)
Pay Items to all (or selected)
Features to all (or selected)
Database: In the output box under database click on the 
ellipses (the three dots) to set the file path and name the new
mdb for the project. 
Mode: Set the mode radial to Create (or append)
Phase: Select the desired phase (Design, Final or Primary) 
from the drop down menu

Quantities
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 Under the pay items tab click in the box 
beside the top folder to select all the items in 
the pay item database (but it will only 
compute the ones tied to features) or select 
only the items that need to be computed.

 Under the features tab in the top surface 
box: highlight the summary surface (the 
surface carrying the features with the pay 
items attached)

 In the features box, select the features that 
need to be computed.

NOTE: Right click inside the features box to select
all. Compute Quantities will only compute the
features that have been selected.

 Click the apply button to compute the 
selected features.

Once the apply button is selected at the 
bottom of the MicroStation screen it will say 
Processing…..

When it finishes computing, the MicroStation
screen will say the database has been 
created similar to the screen capture shown 
to the right. It will also give the path and the 
file name.

Quantities
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 The next step is Quantities>Quantity 
Manager (D>7)

 In the top left corner  Project> Open

 Set the file to the one created with compute 
quantities (there is a magnifying glass to 
select to set the path and file)

 Click the connect button

 All the computed quantities from the features 
will appear in the Quantity Manager

 By selecting the plus sign beside the pay 
item folders each computed pay item will 
show in the window

 By selecting a single pay item the quantity 
will appear in the top right window 

Once all of the quantities in Quantity Manager, 
with all the items highlighted (use the shift and 
control keys to highlight as many items as 
desired)
Tools>Reports>Create
Select the style sheet sample pay item by 
funding
Name the report
Click create
Open the file
Make modifications so all the columns are 
viewable, etc.
Highlight the entire area that needs to be 
pasteed
Right click and copy

Quantities
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 Now open the Pay Quantities design file in MicroStation that the 
quantities will be pasted to. Edit > Paste Special

 Select Embedded Microsoft Office Excel Worksheet

 Place the box where the pay item box is desired

 By double clicking in the box the spread sheet will open, allowing 
any necessary additional changes.

Pay Quantities into MicroStation

9.7



  CHAPTER 10

      Helpful Tools



Notes



From the InRoads menu Tools>Style Manager (F>6)

From the New Style 
window under the general 
subfolder select the desired
include definition for (in this
example the surface 
feature will be shown). Key 
in the new name. If desired 
key in a description

Under the Settings subfolder for Surface Feature select 
the desired check boxes. This will determine how and 
where the feature is allowed to display.
Under the Symbology subfolder, either pick from the 
drop down menu for symbology name or select the new
button and create new symbology.  This will determine 
the points, text, and lines’ level color linestyle and 
weight in plan, profile, and cross sections.
 Note: if the desired result is the same in all three 
locations, it is possible to simply elect to set up the 
defaults.
Key in the new name and description and double click 
on the desired items to set them up.

Note: it is only possible to select a
cell from the current active cell 
library.

LINE SYMBOLOGY

POINT SYMBOLOGY
Using a symbol

TEXT SYMBOLOGY

POINT SYMBOLOGY
Using a cell

InRoads Style Creation
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      Currently, all text generated by InRoads is 100 Scale.  For text at 50 or 20 Scale, the Global 
Scale Factors option can be used.  This option can increase or decrease the size of text 
without having to reset numerous preferences.

Activating Global Scale Factors- To activate the 
Global Scale Factors menu, select Tools => 
Application Add-Ins.  This will display the Applications 
Add-Ins window.

Scroll through the list and select the Global Scale Factors Add-In by clicking its box.  
Click the OK button.

The Global Scale Factors button is now added to the bottom of the Tools menu.
Selecting the Global Scale Factors button will display its window.  To change the Scale factor, 
simply highlight the text field and type in the desired scale.  For example, for 50 scale
sheets, type in 50.  Please note that the scale factors for cells is generally set within the
command placing the cell (in P & P Generator, for example) so the Global Scale Factor
should be left at “1".  

Once the desired scale is entered, click the Apply button to activate the new scale. 
Remember, this does not affect the regular MicroStation text commands.

Using Global Scale Factors with InRoads
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Feature Filter lock
When the lock is on, only surface features that meet the criteria of the active Feature Selection 
Filter are displayed in the surface features list on any dialog box. Limiting the surface features in 
this way allows those commands to operate only on the surface features that meet the filter criteria.
When the lock is off, surface feature filters have no effect, and surface features lists on dialog 
boxes show every feature in the Digital Terrain Model (DTM).

From the Microstation Tools Menu> Tool 
Boxes select to turn on the InRoads Tools 
Locks.

Move the new InRoads Tools Locks- Task 
window and dock it just above the 
Microstation Task pane.

This will allow the viewing of which locks are on at all times 
without the InRoads explorer menu visible. 

Feature Highlight Lock 
This command turns on or off the Feature Highlight lock.  Use this command to highlight 
selected features in plan view.
Effect on Commands with a Feature List View:
When the lock is on, any commands that include a feature list field highlights the feature 
in plan view when it is selected in the list. While this primarily affects Surface commands,
it also applies to Evaluation commands that include feature lists.

Turn on the Feature Highlight Lock by selecting Feature Highlight Lock On from the 
locks tool bar.  From any command that includes a list of features, on screen it will 
highlight any selected feature.

The locks toolbar

10.3



Style Lock
The main concept behind the Style lock is data-driven symbology. The Style locks affects two 
groups of commands: the View Surface commands, and the Annotate Cross Section command.
The effect of the Style lock is different for the View Surface commands than for the Cross 
Section commands.

The locks toolbar

This lock forces the command to read from the symbology tied to the feature instead of the 
symbology set up within the command.

The Pencil/Pen lock
 applies to plan display only. It does not apply to cross sections or 
profiles. This command toggles the Pencil/Pen lock between Pencil 
mode and Pen mode. This lock affects the display of virtually every 
piece of plan graphics representing surfaces or geometry. The 
Pencil/Pen lock controls what happens when a piece of graphics is 
redisplayed. The two actions that might occur are: 1) the new graphics 
will be displayed in addition to the old ones (Pen mode), or 2) the new 
graphics will replace the old ones (Pencil mode).
Pen mode  would be used when it is necessary to keep the previous 
work displayed and not lose it when it is modified, and redisplay the 
surface or geometry. Pencil mode, on the other hand, is a convenience 
because it automatically cleans up the graphics from the previous work 
as it is modified in the design and redisplay. The following two points 
summarize the basic notion of each mode:
•Pen mode – graphics are permanent; allows duplicates (see the Delete 
Ink lock)
•Pencil mode – graphics persist only until the item is redisplayed; no 
duplicates
It is critical to understand that the current setting of the Pencil/Pen lock 
is irrelevant in determining what will happen when a piece of graphics is 
redisplayed. What is relevant is whether the existing graphics were 
displayed in Pencil mode or in Pen mode.
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The Delete Ink lock 
allows redisplayed graphics to replace graphics that were drawn in Pen mode. Normally, 
graphics that were drawn in Pen mode (an alignment, for example) are not removed when 
redisplaying; however, if the Delete Ink lock is on when redisplay is used, the previous graphics 
– even if drawn in Pen mode – will be replaced. Graphics drawn in Pen mode are said to be 
drawn in ink.

The locks toolbar

Locate Lock

The lock applies when using a locate button to specify a position in the graphics file. (Locate 
buttons are found throughout the interface. Each button is indicated by crosshairs icon.) The 
Locate lock determines whether to snap to graphics displayed in the graphics file or to snap to the 
position occupied by a feature in the active surface.
If the lock is set to graphics (the icon shows a single, red line), locate actions will seek the nearest 
displayed graphics.
If the lock is set to features (the icon shows an image of a surface), locate actions will seek the 
position of the nearest feature in the active surface whether or not the feature is actually displayed.
It is possible to use the locate lock to locate features that are not even displayed. If they exist in the
DTM, the locate will find them.

Element Snap Lock
The Element Snap lock enables or disables the ability to snap or lock onto any geometry element 
(any object that would require multiple data points to define) in the geometry project. Use this lock 
to aid in using the direction, distance, length, radius, and/or angle of an existing geometry element 
to design a new element. With this lock toggled on, the software snaps to the element nearest the 
data point placed in the drawing file. This lock and the Point Snap lock are mutually exclusive.
When using a point pick button element snap will snap to a point in the same manner as Point 
Snap.

10.5

No Snap Lock
When choosing No Snap mode, the lock has no effect on the ability to snap to geometry.



The locks toolbar

Point Snap Lock
The Point Snap lock enables or disables the ability to snap or lock onto any point contained in the 
geometry project. Use this lock to aid the placement process of geometry elements. For example, if
it is needed to input point data into a dialog box, then it is possible to toggle this lock on and place 
a data point in the drawing file. The software finds the closest point and displays the point data in 
the dialog box. The Point Snap lock and the Element Snap lock are mutually exclusive.

Station Lock
The Station lock is applicable only when the first station specified on the horizontal alignment is an 
odd-numbered station (for example, 2+38) and when generating cross sections, executing the 
Roadway Designer, or generating station type reports. When this lock is turned on, the software 
applies a given command action to the first station and then forces all subsequent actions to even-
numbered stations. For example, if the first station is 2+38 and the station interval is defined as 
50, the software performs the command action at stations 2+38, 2+50, 3+00, and so on. When 
the Station lock is turned off and the first station is odd-numbered, the software performs the 
command action at odd-numbered stations only (for example, 2+38, 2+88, 3+38).

Report Lock
The Report lock is used by several commands to control whether or not the command displays 
output in a dialog box as the command calculations are performed. If this lock is off, the command 
processes and stores results without displaying them in an output dialog box.

Cogo Audit Trail
This document defines the coordinate geometry audit trail. The intent of the audit trail is to record 
all coordinate geometry results to a text file. The results are the same as the results that are 
displayed in the Results Dialog box when report lock is toggled on.
This lock displays on the Locks Toolbar and the Tools > Locks menu.
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Drafting Notes
The place plan note is great for labeling toes.
First view the features using the Surface>View 
Surface>Features (W>1>5)
And select the features from the list on the View 
Features window desired to label (such as top of 
cut and toe of slope). Select the apply button and 
close the View Features window.

10.7

Select the Plan Note command. 
Drafting>Place Plan Note (D>1)

Before the drafting notes can be 
used, the notes.dft file must be 
loaded. Go to File on the Place 
Plan Note window and navigate to: 
R:\CADD_Support\Design\InRoad
s\notes.dft

Select the plus sign next to the Plan folder from the Notes 
File box on the Place Plan window.
Next select the plus sign next to the folder Proposed. Select
the Feature Style (USE FOR TOES and etc.)and select the 
Apply button on the Place Plan Note window. Select on one 
of the features and accept to see the note. Move the cursor 
where the note will be located and accept again to place the
note.  Note: once the command is rejected, the Apply button
on the Place Plan Note window will need to be selected 
again to use the command.



Drafting Notes

10.8

Place Cross Section Notes

Select Place Plan Note>Place Cross Section Note (D>3).  For example, to annotate existing 
structures use the Existing folder from the Sections folder. Select the note Existing S&S Structure 
and click apply.  In Microstation click on the structure in the cross sections and  accept to get the 
note move where it is needed and accept to place the note.  If annotating flowline elevations,  use 
the LT or RT Existing Flowline note and take care to snap on the top of the bottom set of lines 
accept it and move the note where it should be located and accept again.

Make sure the notes.dft file is loaded in the project defaults or 
load it from the Place Cross Section Note window by selecting 
File>Open and navigate to 
R:\CADD_Support\Design\InRoads\notes.dft
To use this command it is necessary be in the file in Microstation 
that contains the cross sections set that need to be annotated.



  CHAPTER 11

          Reports

                                               Written by: Josh Jones



Notes



Horizontal Alignment Review: 
Go to the Geometry tab in the InRoads workspace bar.
Right click on the alignment that needs to be veiwed.
Click review.  

It is possible to set which 
alignment will be viewed at 
the top of the Review Horiz.
Align. window.  

All reports are found from the InRoads 
Commands task menu under 
Tools>XML Reports (G>1)

11.1

Guideline for Reports:



After clicking apply, the Horizontal Alignment Review Report will appear. 

On the InRoads task menu, go to Tools>XML Reports>Geometry (F>1>1) 

  Under Horiz. Alignments Include: Type in the name of the alignment > press tab > select the
alignment in the box

  Check on Include Horiz. Event Points

  Check on the Interval box and set the interval > click apply

11.2

Horizontal Align. Review with Event 
Points 



Go to the Geometry tab in the InRoads menu. 
Click the plus sign on the horizontal align. 
Right click on the vertical align > click review.

The vertical and/or 
horizontal that needs a 
report to show can be 
changed. 

Click on the HorizontalEvents.xsl to view the Horiz. Events Report.

11.3

Vertical Align. Review: 



Click on the HorizontalAndVerticalAlignmentReview.xsl. The Horiz. information is 
listed first followed by the vertical.

On the InRoads menu, go to Tools>XML Reports>Geometry (F>1>1)
 Enter in the horiz. alignment and then press tab, or if the alignment is already there, select the

horiz. from the box. 
 Check the Include Vertical Alignments check box 
 Select All for all alignments or Active for the active alignment

11.4

Horizontal and Vertical Alignment Review 



Click on the StationOffset.xsl report.

On the InRoads menu go to Tools>XML Reports>Station Offset (F>1>3)
 Set the horiz. align. 
 Click the Include subfolder and check the box next to the points needed
 Click the Horiz. Align. subfolder to add info. for an additional horiz. align.
 Click the Features subfolder to see features from a selected surface. NOTE: When the 

features are listed in the window select the features which need to  be seen in the report. 
Right clicking in the window will allow select all button to be used. Click apply

11.5

Station Offset Report:



Select the Station Offset Report
Under the General subfolder select the primary alignment
On the Include subfolder select  and set the interval
On Horizontal Alignments subfolder select another alignment (the one which will be compared)
Click apply

11.6

To Run Offset Data to compare alignments:



On the InRoads menu, go to Tools>XML Report>Clearance (F>1>4)

 Click the Features subfolder.

 Select the surface

 Select only 2 features 

 NOTE: This report only works properly between 2 like features. Another report will need to be 
run if another Feature to Feature report needs to be seen. 

 Click apply NOTE: This may take a while to generate.

11.7

Feature to Feature: 



On the InRoads menu, go to Tools>XML Report>Clearance (F>1>4) 

 Click the Features subfolder

 Select the surface

 Select the feature that needs a report of

 Click apply

11.8

Feature Station Elevation: 



 Click on the FeatureStationElevationOffset.xsl report.

On the InRoads menu go to Tools>XML Reports>Clearance (F>1>4)

 In the General subfolder select the desired horiz. align. This is the alignment the 
stationing comes from. 

 Check the box next to any points that need to be seen

 In the Features subfolder, select any feature that needs to be veiwed

 Click apply

11.9

Feature Station Elevation Offset: 



Browse to the file in explorer and right click on the file and select open with Excel. Then once 
inside the file, select the columns that need to be deleted and right click on the letter at the top. 
Select delete from the pull down menu.

Save as HTML file

Many of the reports output to an html file.  These files can be opened with Excel and edited 
to give the desired results. To do this go to file Save As on the report browser window

Edit Report Content

11.10


